summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEvgeny Shvits2019-03-29 01:23:30 +0300
committerEvgeny Shvits2019-03-29 01:23:30 +0300
commitb2478a76005561b6c9ccfecd80a90663464dc501 (patch)
treee1a9f4d87a69c0d6b86f394e8a3bc230b29893b1
parent8daa517177191260a3fa76097d4b41ee137df001 (diff)
downloadaur-b2478a76005561b6c9ccfecd80a90663464dc501.tar.gz
Motherfucker fix
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD7
-rw-r--r--xpiks-build_with_system_libquazip5.patch (renamed from xpiks-build_with_system_libquazip5.diff)0
-rw-r--r--xpiks-libxpks_stub.patch32
5 files changed, 41 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4feaf9daaef8..e43e1d16c38a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,10 +16,12 @@ pkgbase = xpiks
depends = quazip
depends = perl-image-exiftool
source = xpiks::git+https://github.com/ribtoks/xpiks.git#tag=v1.5.2
- source = xpiks-build_with_system_libquazip5.diff
+ source = xpiks-build_with_system_libquazip5.patch
+ source = xpiks-libxpks_stub.patch
source = xpiks.desktop
md5sums = SKIP
md5sums = 8d082ec0a08051aec943aa3c35486592
+ md5sums = cf8d93fcf7d19aa5768024752de0994a
md5sums = 4112f7181afe7e45eb878b8eccc91eaf
pkgname = xpiks
diff --git a/.gitignore b/.gitignore
index 343044b8420c..c97359a2a6a8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
src/
pkg/
xpiks/
-xpiks-*.pkg.tar*
+xpiks-*.pkg.tar* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index e44b203b60c1..1819f1c9e327 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,17 +14,20 @@ makedepends=('git')
source=(
"${_gitname}::git+https://github.com/ribtoks/xpiks.git#tag=v1.5.2"
- "xpiks-build_with_system_libquazip5.diff"
+ "xpiks-build_with_system_libquazip5.patch"
+ "xpiks-libxpks_stub.patch"
"xpiks.desktop"
)
md5sums=('SKIP'
'8d082ec0a08051aec943aa3c35486592'
+ 'cf8d93fcf7d19aa5768024752de0994a'
'4112f7181afe7e45eb878b8eccc91eaf')
prepare() {
cd "${srcdir}/${_gitname}"
- git apply ../../xpiks-build_with_system_libquazip5.diff
+ git apply ../../xpiks-build_with_system_libquazip5.patch
+ git apply ../../xpiks-libxpks_stub.patch
git submodule update --init --recursive
}
diff --git a/xpiks-build_with_system_libquazip5.diff b/xpiks-build_with_system_libquazip5.patch
index bd3dbd134bbe..bd3dbd134bbe 100644
--- a/xpiks-build_with_system_libquazip5.diff
+++ b/xpiks-build_with_system_libquazip5.patch
diff --git a/xpiks-libxpks_stub.patch b/xpiks-libxpks_stub.patch
new file mode 100644
index 000000000000..ebb396955e35
--- /dev/null
+++ b/xpiks-libxpks_stub.patch
@@ -0,0 +1,32 @@
+diff --git a/src/libxpks_stub/Microstocks/apisecretsstorage.cpp b/src/libxpks_stub/Microstocks/apisecretsstorage.cpp
+index 080326de..f3482e16 100644
+--- a/src/libxpks_stub/Microstocks/apisecretsstorage.cpp
++++ b/src/libxpks_stub/Microstocks/apisecretsstorage.cpp
+@@ -5,6 +5,27 @@ namespace libxpks {
+ namespace microstocks {
+ APISecretsStorage::APISecretsStorage()
+ {
++ /*
++ * Init keypairs
++ */
++ Encryption::SecretPair ShutterstockClientID, ShutterstockClientSecret, FotoliaAPIKey, GettyAPIKey;
++
++ ShutterstockClientID.m_Key = "MasterPassword";
++ ShutterstockClientID.m_Value = "28a2a9b917961a0cbc343c81b2dd0f6618377f9210aa3182e5cc9f5588f914d918ede1533c9e06b91769c89e80909743";
++
++ ShutterstockClientSecret.m_Key = "MasterPassword";
++ ShutterstockClientSecret.m_Value = "5092d9a967c2f19b57aac29bc09ac3b9e6ae5baec1a371331b73ff24f1625d95c4f3fef90bdacfbe9b0b3803b48c269192bc55f14bb9c2b5a16d650cd641b746eb384fcf9dbd53a96f1f81215921b04409f3635ecf846ffdf01ee04ba76624c9";
++
++ FotoliaAPIKey.m_Key = "MasterPassword";
++ FotoliaAPIKey.m_Value = "ad2954b4ee1e9686fbf8446f85e0c26edfae6003f51f49ca5559aed915879e733bbaf2003b3575bc0b96e682a30a69907c612865ec8f4ec2522131108a4a9f24467f1f83befc3d80201e5f906c761341";
++
++ GettyAPIKey.m_Key = "MasterPassword";
++ GettyAPIKey.m_Value = "17a45639c3bf88f7a6d549759af398090c3f420e53a61a06d7a2a2b153c89fc9470b2365dae8c6d92203287dc6f69f55b230835a8fb2a70b24e806771b750690";
++
++ m_Storage.insert(Microstocks::ShutterstockClientID, ShutterstockClientID);
++ m_Storage.insert(Microstocks::ShutterstockClientSecret, ShutterstockClientSecret);
++ m_Storage.insert(Microstocks::FotoliaAPIKey, FotoliaAPIKey);
++ m_Storage.insert(Microstocks::GettyAPIKey, GettyAPIKey);
+ }
+
+ bool APISecretsStorage::tryFindPair(int key, Encryption::SecretPair &secretPair) {