summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohan Svensson2015-06-16 11:29:22 +0200
committerJohan Svensson2015-06-16 11:29:22 +0200
commit4343de1830e7d57ee33ea183ef494f69463c7496 (patch)
tree96f09213b0c4b59c042542e89f400cf08a5864d4
downloadaur-4343de1830e7d57ee33ea183ef494f69463c7496.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--xping.install9
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e10bf5798b0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xping
+ pkgdesc = A simple ping program continiously probing multiple hosts using icmp-echo
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/martintopholm/xping
+ install = xping.install
+ arch = any
+ license = THE BEER-WARE LICENSE
+ depends = libevent
+ source = git://github.com/martintopholm/xping.git#tag=v1.3
+ md5sums = SKIP
+
+pkgname = xping
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf8c102a1eee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Johan Svensson <johan@loxley.se>
+pkgname=xping
+pkgver=1.3
+pkgrel=1
+pkgdesc="A simple ping program continiously probing multiple hosts using icmp-echo"
+url="https://github.com/martintopholm/xping"
+arch=('any')
+license="THE BEER-WARE LICENSE"
+depends=('libevent')
+source=("git://github.com/martintopholm/$pkgname.git#tag=v$pkgver")
+md5sums=('SKIP')
+install='xping.install'
+CPPFLAGS="-Wall -Werror -I/usr/local/include"
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm4555 "$srcdir/$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm444 "$srcdir/$pkgname/$pkgname.8.gz" "$pkgdir/usr/share/man/man8/$pkgname.8.gz"
+}
diff --git a/xping.install b/xping.install
new file mode 100644
index 000000000000..dbd2e29c440c
--- /dev/null
+++ b/xping.install
@@ -0,0 +1,9 @@
+post_install() {
+cat <<End-of-message
+
+ xping will be installed set-uid because most platforms requires
+ superuser privileges to open RAW sockets. xping drops the privileges
+ when it has opened the sockets.
+
+End-of-message
+}