summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Schnick2023-09-27 03:59:41 +0000
committerChristopher Schnick2023-09-27 03:59:41 +0000
commit6459ecfefb082df081a45ac912042ec678919c35 (patch)
tree074ff2d6c5d3e9269226c0cf9363916a16ca4850
parent997399dbf994138915ab3ee8a7111631bb210f0b (diff)
downloadaur-6459ecfefb082df081a45ac912042ec678919c35.tar.gz
Update to version unspecified
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD27
-rw-r--r--xpipe.changelog38
-rw-r--r--xpipe.desktop14
4 files changed, 63 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 298c1cd16de6..6faa5cd82150 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xpipe
- pkgdesc = A brand-new shell connection hub and remote file manager
- pkgver = 1.5.3
+ pkgdesc = The shell connection hub and remote file browser for your entire infrastructure
+ pkgver = 1.6.0
pkgrel = 1
epoch = 1
url = https://github.com/xpipe-io/xpipe
@@ -10,9 +10,9 @@ pkgbase = xpipe
license = unknown
source = xpipe.desktop
sha512sums = SKIP
- source_x86_64 = xpipe-1.5.3-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.5.3/xpipe-portable-linux-x86_64.tar.gz
+ source_x86_64 = xpipe-1.6.0-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.6.0/xpipe-portable-linux-x86_64.tar.gz
sha512sums_x86_64 = SKIP
- source_aarch64 = xpipe-1.5.3-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.5.3/xpipe-portable-linux-arm64.tar.gz
+ source_aarch64 = xpipe-1.6.0-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.6.0/xpipe-portable-linux-arm64.tar.gz
sha512sums_aarch64 = SKIP
pkgname = xpipe
diff --git a/PKGBUILD b/PKGBUILD
index 44d0acd72c0a..5bd91951dca5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Christopher Schnick <crschnick@xpipe.io>
-pkgname=xpipe
-pkgver=1.5.3
-pkgrel=1
+_fullver="1.6.0"
+pkgname="xpipe"
+pkgver="1.6.0"
+pkgrel="1"
epoch=1
-pkgdesc="A brand-new shell connection hub and remote file manager"
+pkgdesc="The shell connection hub and remote file browser for your entire infrastructure"
arch=('x86_64' 'aarch64')
-url="https://github.com/xpipe-io/xpipe"
+url="https://github.com/xpipe-io/${pkgname}"
license=('unknown')
groups=()
depends=()
@@ -20,9 +21,9 @@ backup=()
options=()
install=
changelog="xpipe.changelog"
-source=("xpipe.desktop")
-source_x86_64=("${pkgname}-${pkgver}-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/${pkgver}/xpipe-portable-linux-x86_64.tar.gz")
-source_aarch64=("${pkgname}-${pkgver}-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/${pkgver}/xpipe-portable-linux-arm64.tar.gz")
+source=("${pkgname}.desktop")
+source_x86_64=("${pkgname}-${_fullver}-x86_64.tar.gz::https://github.com/xpipe-io/${pkgname}/releases/download/${_fullver}/xpipe-portable-linux-x86_64.tar.gz")
+source_aarch64=("${pkgname}-${_fullver}-arm64.tar.gz::https://github.com/xpipe-io/${pkgname}/releases/download/${_fullver}/xpipe-portable-linux-arm64.tar.gz")
noextract=()
sha512sums=("SKIP")
sha512sums_x86_64=("SKIP")
@@ -30,10 +31,10 @@ sha512sums_aarch64=("SKIP")
package() {
install -dm0755 "$pkgdir/opt"
- cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/$pkgname"
- install -Dm0644 -t "$pkgdir/usr/share/applications/" "$srcdir/xpipe.desktop"
+ cp -a "$srcdir/xpipe-${_fullver}" "$pkgdir/opt/$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname}.desktop"
install -d "$pkgdir"/usr/bin
- ln -s "/opt/$pkgname/cli/bin/xpipe" "$pkgdir/usr/bin/xpipe"
+ ln -s "/opt/$pkgname/cli/bin/xpipe" "$pkgdir/usr/bin/${pkgname}"
install -d "$pkgdir"/etc/bash_completion.d
- ln -s "/opt/xpipe/cli/xpipe_completion" "$pkgdir/etc/bash_completion.d/xpipe"
-} \ No newline at end of file
+ ln -s "/opt/xpipe/cli/xpipe_completion" "$pkgdir/etc/bash_completion.d/${pkgname}"
+}
diff --git a/xpipe.changelog b/xpipe.changelog
index e69de29bb2d1..8a7a284b1051 100644
--- a/xpipe.changelog
+++ b/xpipe.changelog
@@ -0,0 +1,38 @@
+## Changes in 1.6.0
+
+- Implement new category tree organization functionality for connections
+- Rework connection chooser in popup window and in file browser
+- Rework user interface
+- Add support for sharing your storage via a remote git repository
+- Add support for a transparent window mode
+- Upgrade to GraalVM 21
+- Improve command process synchronization to try to fix rare race conditions and deadlocks
+- Dynamically check whether kubectl requires elevation to fix permission issues, for example when using rancher k3s
+- Add attach and logs context menu actions for docker containers
+- Add support for VSCode Insiders
+- Add support for ElementaryOS terminal
+- Add support ash shells
+- Improve error handler to also show a graphical window before the application window is opened
+- Make shell environment init script apply changes to the shell session by sourcing it
+- Rework powershell execution policy usage to not override system default
+- Improve resilience of storage loading and saving in case of IO errors
+- Improve browser tab naming and sizing
+- Automatically apply local clipboard changes to browser
+- Preserve clipboard contents after exit
+- Add support to open ssh: URLs
+- Add functionality to open ssh connections in Termius
+- Add functionality to open ssh connections in default SFTP client
+- Add functionality to create desktop shortcuts and URLs for certain actions within XPipe
+- Rework installer packages
+- Properly query desktop directory on Windows and Linux in case it was at non-standard locations
+- Check whether target exists when renaming or moving in file browser
+- Fix ssh config entry being added even if it was empty
+- Fix passcode PAM authentication caching responses
+- Fix Powershell remote sessions not working correctly
+- Many other small miscellaneous fixes and improvements
+
+## Experimental releases
+
+There are already many other feature branches in the pipeline and will be released soon.
+In fact as of now, you can already try out the next major 1.7 release in the [XPipe PTB](https://github.com/xpipe-io/xpipe-ptb) (Public Test Build).
+The regular releases and new PTB releases are designed to not interfere with each other and can therefore be installed and used side by side.
diff --git a/xpipe.desktop b/xpipe.desktop
index f72533177ac1..5ea89fac45a0 100644
--- a/xpipe.desktop
+++ b/xpipe.desktop
@@ -1,13 +1,13 @@
[Desktop Entry]
Type=Application
-Name=XPipe
-Comment=A brand-new type of connection manager and remote file explorer
-TryExec=/opt/xpipe/app/bin/xpiped
-Exec=/opt/xpipe/cli/bin/xpipe open %U
-Path=/opt/xpipe/app
-Icon=/opt/xpipe/logo.png
+Name=__NAME__
+Comment=__DESCRIPTION__
+TryExec=__TARGET__/app/bin/xpiped
+Exec=__TARGET__/cli/bin/xpipe open %U
+Path=__TARGET__/app
+Icon=__TARGET__/logo.png
Terminal=false
Categories=Utility;Development;
StartupNotify=true
StartupWMClass=io.xpipe.app.core.App
-MimeType=x-scheme-handler/xpipe
+MimeType=x-scheme-handler/xpipe;x-scheme-handler/ssh