summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Schnick2024-01-05 10:35:04 +0000
committerChristopher Schnick2024-01-05 10:35:04 +0000
commit91e79ba364bd1b28f982103e05f2cc52aabd2924 (patch)
tree8ce67437ca7a4a438c4232db4e9e1b907ff686bf
parent18c80228ae10407f858811121ccd7b9c2fcb6a2d (diff)
downloadaur-91e79ba364bd1b28f982103e05f2cc52aabd2924.tar.gz
Update to version 1.7.13
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--xpipe.changelog60
3 files changed, 51 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01176d2b31a0..2a1d9ed76946 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xpipe
pkgdesc = Your entire server infrastructure at your fingertips
- pkgver = 1.7.12
+ pkgver = 1.7.13
pkgrel = 1
epoch = 1
url = https://github.com/xpipe-io/xpipe
@@ -8,11 +8,21 @@ pkgbase = xpipe
arch = x86_64
arch = aarch64
license = unknown
+ depends = cairo
+ depends = freetype2
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gperf
+ depends = gtk3
+ depends = libgl
+ depends = libx11
+ depends = libxtst
+ depends = pango
source = xpipe.desktop
sha512sums = SKIP
- source_x86_64 = xpipe-1.7.12-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.12/xpipe-portable-linux-x86_64.tar.gz
+ source_x86_64 = xpipe-1.7.13-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.13/xpipe-portable-linux-x86_64.tar.gz
sha512sums_x86_64 = SKIP
- source_aarch64 = xpipe-1.7.12-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.12/xpipe-portable-linux-arm64.tar.gz
+ source_aarch64 = xpipe-1.7.13-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.13/xpipe-portable-linux-arm64.tar.gz
sha512sums_aarch64 = SKIP
pkgname = xpipe
diff --git a/PKGBUILD b/PKGBUILD
index 609bd8a377bf..06c94ee4ac11 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Christopher Schnick <crschnick@xpipe.io>
-_fullver="1.7.12"
+_fullver="1.7.13"
pkgname="xpipe"
-pkgver="1.7.12"
+pkgver="1.7.13"
pkgrel="1"
epoch=1
pkgdesc="Your entire server infrastructure at your fingertips"
@@ -10,7 +10,19 @@ arch=('x86_64' 'aarch64')
url="https://github.com/xpipe-io/${pkgname}"
license=('unknown')
groups=()
-depends=()
+# From https://aur.archlinux.org/packages/java-openjfx
+depends=(
+ cairo
+ freetype2
+ gdk-pixbuf2
+ glib2
+ gperf
+ gtk3
+ libgl
+ libx11
+ libxtst
+ pango
+)
makedepends=()
checkdepends=()
optdepends=()
diff --git a/xpipe.changelog b/xpipe.changelog
index fa82ffc376c3..93746b63e0f8 100644
--- a/xpipe.changelog
+++ b/xpipe.changelog
@@ -1,42 +1,28 @@
-## New professional features
-
-- Add ability to open files and directories in VSCode SSH remote environment in file browser
-- Added support for fully offline licenses. You can obtain them via email request
- in case you're running it on a system without internet connectivity or restricted proxy settings
-
## Changes
-- Make current default shell also show up in shell environments to prevent confusion about missing bash environment
-- Improve error messages when an additional password was requested by the connection
- when none was provided instead of just showing permission denied
-- Make SSH connection starting from a WSL environment use the native Windows key helper for FIDO2 keys
-- Rework insights button for connection creation across the board
-
-## Additions
-
-- Add warning message if git vault URL was an HTTP URL and you are trying to use an SSH identity
-- Add ability to clone existing connections to make the process of adding similar connections easier
-- Add ability to debug local background shell in developer options
-- Add notice when a professional feature is available in preview mode
-- Add some more OS logos
-- Add check to verify whether font loading with fontconfig works on Linux on startup
-- Add more extensive note on first startup for potential issues when Malwarebytes, McAfee, or Bitdefender are installed
+- You can now add SSH connections from arbitrary OpenSSH config files under `Add remote host` -> `SSH Config`
+- The SSH config importer now supports include statements. Included files are automatically resolved and joined
+- Add experimental ability to automatically fix SSH key file permissions on Windows if OpenSSH complains
+- Rework file browser connection history overview to always update when you close a tab
+- The Linux installers now correctly report their dependencies. This was not really a problem on any
+ normal desktop system, but should make it easier to run on embedded systems or in WSL2g
+- Improve performance mode speedup by removing more styling. You can enable the mode under Settings -> Appearance
+- Change layout of connection names and status to better handle very long connection names across all window sizes
+- Make any connection quickly renameable in the edit window without verifying whether we can actually connect
+- Allow for creation of multiple connections with the same name
+- Add a self test functionality on startup to handle cases where the local shell could not be initialized correctly
+- Implement fallback to bundled fonts on Linux systems that do not have fontconfig
+- There is now a repository for nixos releases at https://github.com/xpipe-io/nixpkg
+- Improve documentation for custom terminal command setting
## Fixes
-- Fix application not starting on Asahi Linux due to executable page size issue
-- Fix file existence check for SSH key files reporting wrong results on Windows in directory links/junctions
-- Fix k8s integration not working when user did not have permission to list nodes
-- Fix rare error when switching to tray operation mode on Linux
-- Fix connection state not being preserved when being added the first time
-- Fix application failing to start up if OS reported invalid screen size bounds
-- Fix VMware VM not being able to be parsed if configuration file did not specify an encoding or name
-- Fix startup failing when installation was located on a ramdisk
-- Fix some miscellaneous cache data being stored in the user home directory
-- Fix error handling when jump host chain formed a loop
-- Fix PowerShell remote sessions being blocked by execution policy
-- Fix race condition when locking user data directory
-- Fix some CLI commands not starting daemon correctly if it is not already running
-- Fix text field when showing askpass window not being focused automatically
-- Fix combobox selections not working well with keyboard-only workflows
-- Fix many possible small NullPointerExceptions
+- Fix some zsh shells not properly setting up the PATH
+- Fix git vault repository throwing initialization errors when shared with multiple Windows user permissions
+- Fix displayed connection summary not updating on edit
+- Fix copying and pasting a file into the same directory returning an error
+- Fix connections being accidentally listed under scripts category
+ if they were added while scripts category was selected
+- Fix default terminal detection sometimes selecting iTerm even though it was not installed
+- Fix shell environments for BSD bourne shell failing with invalid -l switch
+- Fix connections to pfSense systems not working