summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Schnick2024-01-18 20:44:44 +0000
committerChristopher Schnick2024-01-18 20:44:44 +0000
commitaabcebc542519a8021f0008f29707a77fd8a535e (patch)
tree526744613942c1e64d7333d6175b0362b1085a48
parent9bb97917d7cbc5dd98795f4987dc2b58a2555bdd (diff)
downloadaur-aabcebc542519a8021f0008f29707a77fd8a535e.tar.gz
Update to version 1.7.15
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--xpipe.changelog33
3 files changed, 33 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d1bdb144217..1983b0519fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xpipe
pkgdesc = Your entire server infrastructure at your fingertips
- pkgver = 1.7.14
+ pkgver = 1.7.15
pkgrel = 1
epoch = 1
url = https://github.com/xpipe-io/xpipe
@@ -20,9 +20,9 @@ pkgbase = xpipe
depends = pango
source = xpipe.desktop
sha512sums = SKIP
- source_x86_64 = xpipe-1.7.14-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.14/xpipe-portable-linux-x86_64.tar.gz
+ source_x86_64 = xpipe-1.7.15-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.15/xpipe-portable-linux-x86_64.tar.gz
sha512sums_x86_64 = SKIP
- source_aarch64 = xpipe-1.7.14-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.14/xpipe-portable-linux-arm64.tar.gz
+ source_aarch64 = xpipe-1.7.15-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.15/xpipe-portable-linux-arm64.tar.gz
sha512sums_aarch64 = SKIP
pkgname = xpipe
diff --git a/PKGBUILD b/PKGBUILD
index 03690929d639..97e1c703181e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Christopher Schnick <crschnick@xpipe.io>
-_fullver="1.7.14"
+_fullver="1.7.15"
pkgname="xpipe"
-pkgver="1.7.14"
+pkgver="1.7.15"
pkgrel="1"
epoch=1
pkgdesc="Your entire server infrastructure at your fingertips"
diff --git a/xpipe.changelog b/xpipe.changelog
index 952bd412af7b..75f69158ae02 100644
--- a/xpipe.changelog
+++ b/xpipe.changelog
@@ -1,5 +1,28 @@
-This is just a small hotfix update to fix a few important issues:
-- Fix license validation throwing errors due to mismatched date format
-- Fix .deb installers not being able to resolve some packages on Ubuntu < 22
-- Fix command-line installation script on homepage not refreshing package repositories
- on Linux if needed. It also now supports dnf, yum, and zypper as well
+## Changes
+
+- Add support to create customized SSH connections using arbitrary options.
+ This can be done using the SSH config format but without having to create an actual file.
+- Unify all SSH connection types to support the same functionality.
+ I.e. they all now support host key and identity file fixes plus can be used with SSH tunnels.
+- Make it possible to specify any identity to be used for SSH config connections
+- Properly detect when an active connection has unexpectedly reset during a file browser session.
+ It will now be automatically restarted when any action is performed and fails.
+- Rework connection creation menu layout to give a better overview
+- Make the connection timeout value in the settings properly apply to ssh connections as well.
+ This should help with SSH connections that take a long time to connect.
+- Include pre-rasterized images for various sizes to reduce the render load at runtime
+- Implement various performance improvements
+- Rework some UI elements to better work with keyboard navigation and screen readers
+- Add unsupported shell notice when restricted bash is detected
+- The daemon now properly reports any startup failure causes when started from the CLI via `xpipe open`
+- Regularly clean logs directory to free up older log files
+- Improve file browser handling in smaller window sizes
+- Add support for WezTerm and Windows Terminal Preview
+
+## Fixes
+
+- Fix application windows on Linux not initializing with the correct size
+- Fix connections to pfSense systems not working (This time properly)
+- Fix NullPointerException when a Linux system did not provide any release name
+- Fix startup errors when operating system reported invalid window sizes
+- Fix various Exceptions caused by race conditions