summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Schnick2023-10-20 11:01:59 +0000
committerChristopher Schnick2023-10-20 11:01:59 +0000
commitce74fb619399f45b4f02a90c51cfc4ea463b67c2 (patch)
treee804c9f239152114a5dba718fe8127b173823b9f
parent6459ecfefb082df081a45ac912042ec678919c35 (diff)
downloadaur-ce74fb619399f45b4f02a90c51cfc4ea463b67c2.tar.gz
Update to version unspecified
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--xpipe.changelog80
3 files changed, 52 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6faa5cd82150..0645cb19b04e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xpipe
- pkgdesc = The shell connection hub and remote file browser for your entire infrastructure
- pkgver = 1.6.0
+ pkgdesc = Your entire server infrastructure at your fingertips
+ pkgver = 1.7.0
pkgrel = 1
epoch = 1
url = https://github.com/xpipe-io/xpipe
@@ -10,9 +10,9 @@ pkgbase = xpipe
license = unknown
source = xpipe.desktop
sha512sums = SKIP
- source_x86_64 = xpipe-1.6.0-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.6.0/xpipe-portable-linux-x86_64.tar.gz
+ source_x86_64 = xpipe-1.7.0-x86_64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.0/xpipe-portable-linux-x86_64.tar.gz
sha512sums_x86_64 = SKIP
- source_aarch64 = xpipe-1.6.0-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.6.0/xpipe-portable-linux-arm64.tar.gz
+ source_aarch64 = xpipe-1.7.0-arm64.tar.gz::https://github.com/xpipe-io/xpipe/releases/download/1.7.0/xpipe-portable-linux-arm64.tar.gz
sha512sums_aarch64 = SKIP
pkgname = xpipe
diff --git a/PKGBUILD b/PKGBUILD
index 5bd91951dca5..d8268b1c76eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Christopher Schnick <crschnick@xpipe.io>
-_fullver="1.6.0"
+_fullver="1.7.0"
pkgname="xpipe"
-pkgver="1.6.0"
+pkgver="1.7.0"
pkgrel="1"
epoch=1
-pkgdesc="The shell connection hub and remote file browser for your entire infrastructure"
+pkgdesc="Your entire server infrastructure at your fingertips"
arch=('x86_64' 'aarch64')
url="https://github.com/xpipe-io/${pkgname}"
license=('unknown')
@@ -36,5 +36,5 @@ package() {
install -d "$pkgdir"/usr/bin
ln -s "/opt/$pkgname/cli/bin/xpipe" "$pkgdir/usr/bin/${pkgname}"
install -d "$pkgdir"/etc/bash_completion.d
- ln -s "/opt/xpipe/cli/xpipe_completion" "$pkgdir/etc/bash_completion.d/${pkgname}"
+ ln -s "/opt/$pkgname/cli/xpipe_completion" "$pkgdir/etc/bash_completion.d/${pkgname}"
}
diff --git a/xpipe.changelog b/xpipe.changelog
index 8a7a284b1051..2ef43cc99b8c 100644
--- a/xpipe.changelog
+++ b/xpipe.changelog
@@ -1,38 +1,46 @@
-## Changes in 1.6.0
-
-- Implement new category tree organization functionality for connections
-- Rework connection chooser in popup window and in file browser
-- Rework user interface
-- Add support for sharing your storage via a remote git repository
-- Add support for a transparent window mode
-- Upgrade to GraalVM 21
-- Improve command process synchronization to try to fix rare race conditions and deadlocks
-- Dynamically check whether kubectl requires elevation to fix permission issues, for example when using rancher k3s
-- Add attach and logs context menu actions for docker containers
-- Add support for VSCode Insiders
-- Add support for ElementaryOS terminal
-- Add support ash shells
-- Improve error handler to also show a graphical window before the application window is opened
-- Make shell environment init script apply changes to the shell session by sourcing it
-- Rework powershell execution policy usage to not override system default
-- Improve resilience of storage loading and saving in case of IO errors
-- Improve browser tab naming and sizing
-- Automatically apply local clipboard changes to browser
-- Preserve clipboard contents after exit
-- Add support to open ssh: URLs
-- Add functionality to open ssh connections in Termius
-- Add functionality to open ssh connections in default SFTP client
-- Add functionality to create desktop shortcuts and URLs for certain actions within XPipe
-- Rework installer packages
-- Properly query desktop directory on Windows and Linux in case it was at non-standard locations
-- Check whether target exists when renaming or moving in file browser
-- Fix ssh config entry being added even if it was empty
-- Fix passcode PAM authentication caching responses
-- Fix Powershell remote sessions not working correctly
-- Many other small miscellaneous fixes and improvements
+# Update procedure
+
+Note that the automatic updater is broken in version 1.6.0. It will freeze the application and not perform the update. **So do not try to click the install button in XPipe**!
+You have to install it manually from https://github.com/xpipe-io/xpipe/releases/tag/1.7.0. You can easily do this as uninstalling the old version does not delete any user data. Installing a newer version of XPipe also automatically uninstalls any old ones, so you don't have to manually uninstall it.
+
+## Changes in 1.7.0
+
+### Scripts
+
+XPipe 1.7 comes with a new scripting system, you now can take your environment everywhere.
+The idea is to create modular and reusable init scripts in XPipe that will be run on login but are independent of your profile files.
+You can set certain scripts to be executed for every connection, allowing you to create a consistent environment across all remote systems.
+
+As of now, there is only one set of scripts for enabling starship in your shell connections as a proof of concept.
+However, you can contribute custom scripts [here](https://github.com/xpipe-io/xpipe/tree/master/ext/base/src/main/java/io/xpipe/ext/base/script/PredefinedScriptStore.java) and [here](https://github.com/xpipe-io/xpipe/tree/master/ext/base/src/main/resources/io/xpipe/ext/base/resources/scripts).
+
+### Connection states
-## Experimental releases
+The second big change is a rework of the state system.
+This merges the process of validating/refreshing with the process of establishing a connection, allowing for a much faster creation and launch of new connections.
+It also enables a custom display and instant updates of the information displayed for a connection.
+You will definitely notice this change when you connect to a system.
-There are already many other feature branches in the pipeline and will be released soon.
-In fact as of now, you can already try out the next major 1.7 release in the [XPipe PTB](https://github.com/xpipe-io/xpipe-ptb) (Public Test Build).
-The regular releases and new PTB releases are designed to not interfere with each other and can therefore be installed and used side by side.
+### Performance improvements
+
+The entire storage and UI handling of connections has been reworked to improve performance.
+Especially if you're dealing with a large amount of connections, this will be noticeable.
+
+### Colors
+
+You can now assign colors to connections for organizational purposes to help in situations when many connections are opened in the file browser and terminals at the same time.
+These colors will be shown to identify tabs everywhere within XPipe and also outside of XPipe, for example in terminals.
+
+### Other changes
+
+- Codesign executables on Windows
+- Fix application not starting up or exiting properly sometimes
+- Add support for bsd-based systems
+- Fix OPNsense shells timing out
+- Make window transparency setting a slider
+- Save configuration data more frequently to avoid any data loss
+- Fix shutdown error caused by clipboard being inaccessible
+- Fix some environment scripts not being sourced correctly
+- Fix autoupdater not working properly
+- Fix application not exiting properly on SIGTERM
+- Many other small miscellaneous fixes and improvements