summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2020-05-11 09:25:04 -0400
committerBuildTools2020-05-11 09:25:04 -0400
commitf46d128dc107ca57d0dc23a37c5f0ba138a25186 (patch)
treedac77aa53dc60bc3a5f7f843150423bea09702b5
downloadaur-xpipe-git.tar.gz
initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD41
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..54e6bafcddad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xpipe-git
+ pkgdesc = split input and feed it into the given utility
+ pkgver = r11.60b0aec
+ pkgrel = 1
+ url = https://github.com/jschauma/xpipe.git
+ arch = any
+ license = BSD
+ makedepends = git
+ provides = xpipe
+ conflicts = xpipe
+ source = git+https://github.com/jschauma/xpipe.git
+ sha256sums = SKIP
+
+pkgname = xpipe-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5003dd509f2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=xpipe-git
+pkgver=r11.60b0aec
+pkgrel=1
+pkgdesc="split input and feed it into the given utility"
+arch=('any')
+url='https://github.com/jschauma/xpipe.git'
+license=('BSD')
+makedepends=('git')
+source=("git+https://github.com/jschauma/xpipe.git")
+sha256sums=('SKIP')
+conflicts=('xpipe')
+provides=('xpipe')
+
+pkgver() {
+ cd xpipe
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+check() {
+ cd xpipe
+ make test
+}
+
+build() {
+ cd xpipe
+ make
+}
+
+package() {
+ cd xpipe
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ install -d "${pkgdir}/usr/share/man/man1"
+ install -m755 xpipe "${pkgdir}/usr/bin/"
+ install -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -m644 doc/xpipe.1 "${pkgdir}/usr/share/man/man1/"
+}
+
+# vim:set ts=2 sw=2 et: