summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcrschnick2023-09-14 10:44:05 +0200
committercrschnick2023-09-14 10:44:05 +0200
commitfabf0eed373e0fcf2af63796f084d92bc5cffa9a (patch)
tree92f5e88eb8e10ec8757fd0e8aa9931d298bf620d
downloadaur-fabf0eed373e0fcf2af63796f084d92bc5cffa9a.tar.gz
Update to version 1.6.0-3
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--xpipe-ptb.desktop13
-rw-r--r--xpipe.changelog0
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fa71d713b764
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xpipe-ptb
+ pkgdesc = The shell connection hub and remote file browser for your entire infrastructure
+ pkgver = 1.6.0
+ pkgrel = 3
+ epoch = 1
+ url = https://github.com/xpipe-io/xpipe-ptb
+ changelog = xpipe.changelog
+ arch = x86_64
+ arch = aarch64
+ license = unknown
+ source = xpipe-ptb.desktop
+ sha512sums = SKIP
+ source_x86_64 = xpipe-ptb-1.6.0-3-x86_64.tar.gz::https://github.com/xpipe-io/xpipe-ptb/releases/download/1.6.0-3/xpipe-portable-linux-x86_64.tar.gz
+ sha512sums_x86_64 = SKIP
+ source_aarch64 = xpipe-ptb-1.6.0-3-arm64.tar.gz::https://github.com/xpipe-io/xpipe-ptb/releases/download/1.6.0-3/xpipe-portable-linux-arm64.tar.gz
+ sha512sums_aarch64 = SKIP
+
+pkgname = xpipe-ptb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0226431fb84
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Christopher Schnick <crschnick@xpipe.io>
+
+_fullver="1.6.0-3"
+pkgname="xpipe-ptb"
+pkgver="1.6.0"
+pkgrel="3"
+epoch=1
+pkgdesc="The shell connection hub and remote file browser for your entire infrastructure"
+arch=('x86_64' 'aarch64')
+url="https://github.com/xpipe-io/${pkgname}"
+license=('unknown')
+groups=()
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog="xpipe.changelog"
+source=("${pkgname}.desktop")
+source_x86_64=("${pkgname}-${_fullver}-x86_64.tar.gz::https://github.com/xpipe-io/${pkgname}/releases/download/${_fullver}/xpipe-portable-linux-x86_64.tar.gz")
+source_aarch64=("${pkgname}-${_fullver}-arm64.tar.gz::https://github.com/xpipe-io/${pkgname}/releases/download/${_fullver}/xpipe-portable-linux-arm64.tar.gz")
+noextract=()
+sha512sums=("SKIP")
+sha512sums_x86_64=("SKIP")
+sha512sums_aarch64=("SKIP")
+
+package() {
+ install -dm0755 "$pkgdir/opt"
+ cp -a "$srcdir/xpipe-${_fullver}" "$pkgdir/opt/$pkgname"
+ install -Dm0644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname}.desktop"
+ install -d "$pkgdir"/usr/bin
+ ln -s "/opt/$pkgname/cli/bin/xpipe" "$pkgdir/usr/bin/${pkgname}"
+ install -d "$pkgdir"/etc/bash_completion.d
+ ln -s "/opt/xpipe/cli/xpipe_completion" "$pkgdir/etc/bash_completion.d/${pkgname}"
+}
diff --git a/xpipe-ptb.desktop b/xpipe-ptb.desktop
new file mode 100644
index 000000000000..5ea89fac45a0
--- /dev/null
+++ b/xpipe-ptb.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Name=__NAME__
+Comment=__DESCRIPTION__
+TryExec=__TARGET__/app/bin/xpiped
+Exec=__TARGET__/cli/bin/xpipe open %U
+Path=__TARGET__/app
+Icon=__TARGET__/logo.png
+Terminal=false
+Categories=Utility;Development;
+StartupNotify=true
+StartupWMClass=io.xpipe.app.core.App
+MimeType=x-scheme-handler/xpipe;x-scheme-handler/ssh
diff --git a/xpipe.changelog b/xpipe.changelog
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/xpipe.changelog