summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2019-10-06 21:57:20 -1000
committerGaetan Bisson2019-10-06 21:57:20 -1000
commit4fb591af404ea5259e760fe10275d04339219465 (patch)
tree3f1ac28077996bd7de0faa2f79b80f2f49da64d4
parentd3c82726b3959db72dd3dcd207da6e2ee9f1f2ba (diff)
downloadaur-4fb591af404ea5259e760fe10275d04339219465.tar.gz
fix build with freetype
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2702d7f2e8d8..e631a1188480 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xplanet-svn
pkgdesc = Renders an image of the earth into the X root window
- pkgver = 20170111.209
- pkgrel = 1
+ pkgver = 20190922.213
+ pkgrel = 2
url = http://xplanet.sourceforge.net/
arch = i686
arch = x86_64
@@ -16,8 +16,8 @@ pkgbase = xplanet-svn
conflicts = xplanet
source = xplanet::svn://svn.code.sf.net/p/xplanet/code/trunk
source = giflib.patch
- sha1sums = SKIP
- sha1sums = c9fe0f25ddc64c1aaf319d77cb5ddcb64a230667
+ sha256sums = SKIP
+ sha256sums = c9abf31bf242d7c0940e8fbc5b64714c12edd4b995aba1ebe776ddc0c5bf019a
pkgname = xplanet-svn
diff --git a/PKGBUILD b/PKGBUILD
index 8d31f641711d..fef2468b27c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=xplanet-svn
_pkgname=xplanet
-pkgver=20170111.209
-pkgrel=1
+pkgver=20190922.213
+pkgrel=2
pkgdesc='Renders an image of the earth into the X root window'
url='http://xplanet.sourceforge.net/'
arch=('i686' 'x86_64' 'armv7h')
@@ -27,12 +27,14 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 <"${srcdir}/giflib.patch"
+ sed 's: -I`$FREETYPE_CONFIG --prefix`/include::g' -i acinclude.m4
aclocal && autoconf && automake --add-missing
}
build() {
cd "${srcdir}/${_pkgname}"
- ./configure --prefix=/usr --with-freetype
+ export FREETYPE_CONFIG="/usr/bin/pkg-config freetype2"
+ ./configure --prefix=/usr
make
}