summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGaetan Bisson2015-06-08 15:08:35 -1000
committerGaetan Bisson2015-06-08 15:08:35 -1000
commit7b8c0566b7195aab319495a9d688cd89cc625fb1 (patch)
tree4d4b51e7d1648424152c0c1c68fb75e54fb6302d
downloadaur-7b8c0566b7195aab319495a9d688cd89cc625fb1.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..730dec43cae3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = xplanet-svn
+ pkgdesc = Renders an image of the earth into the X root window
+ pkgver = 20130526.202
+ pkgrel = 1
+ url = http://xplanet.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL2
+ makedepends = subversion
+ depends = pango
+ depends = libtiff
+ depends = libxss
+ provides = xplanet
+ conflicts = xplanet
+ source = xplanet::svn://svn.code.sf.net/p/xplanet/code/trunk
+ sha1sums = SKIP
+
+pkgname = xplanet-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e40dfc4c1326
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gaetan Bisson <bisson@archlinux.org
+# Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
+
+pkgname=xplanet-svn
+_pkgname=xplanet
+pkgver=20130526.202
+pkgrel=1
+pkgdesc='Renders an image of the earth into the X root window'
+url='http://xplanet.sourceforge.net/'
+arch=('i686' 'x86_64' 'armv7h')
+license=('GPL2')
+makedepends=('subversion')
+depends=('pango' 'libtiff' 'libxss')
+source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk")
+sha1sums=('SKIP')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ ./configure --prefix=/usr --with-freetype
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ make prefix="${pkgdir}"/usr install
+}