summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilles Chauvin2015-07-07 12:40:47 +0200
committerGilles Chauvin2015-07-07 12:40:47 +0200
commit8b2d6543e60eb4b28c67000403ec6632ab49be17 (patch)
treeacf3f80737c4216f63d4edbd3b2c9d226ea55041
parent7b8c0566b7195aab319495a9d688cd89cc625fb1 (diff)
downloadaur-8b2d6543e60eb4b28c67000403ec6632ab49be17.tar.gz
Update depends + giflib patch
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD15
-rw-r--r--giflib.patch29
3 files changed, 43 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 730dec43cae3..0e2f4d30b967 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,15 @@ pkgbase = xplanet-svn
license = GPL2
makedepends = subversion
depends = pango
+ depends = giflib
depends = libtiff
depends = libxss
provides = xplanet
conflicts = xplanet
source = xplanet::svn://svn.code.sf.net/p/xplanet/code/trunk
+ source = giflib.patch
sha1sums = SKIP
+ sha1sums = c9fe0f25ddc64c1aaf319d77cb5ddcb64a230667
pkgname = xplanet-svn
diff --git a/PKGBUILD b/PKGBUILD
index e40dfc4c1326..eb973a95bc57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Gaetan Bisson <bisson@archlinux.org
-# Contributor: Gilles CHAUVIN <gcnweb@gmail.com>
+# Contributor: Gilles CHAUVIN <gcnweb at gmail dot com>
pkgname=xplanet-svn
_pkgname=xplanet
@@ -10,9 +10,11 @@ url='http://xplanet.sourceforge.net/'
arch=('i686' 'x86_64' 'armv7h')
license=('GPL2')
makedepends=('subversion')
-depends=('pango' 'libtiff' 'libxss')
-source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk")
-sha1sums=('SKIP')
+depends=('pango' 'giflib' 'libtiff' 'libxss')
+source=("${_pkgname}::svn://svn.code.sf.net/p/xplanet/code/trunk"
+ "giflib.patch")
+sha1sums=('SKIP'
+ 'c9fe0f25ddc64c1aaf319d77cb5ddcb64a230667')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
@@ -22,6 +24,11 @@ pkgver() {
svn info | awk '/Revision/{r=$2}/Date/{gsub(/-/,"");d=$4}END{print d"."r}'
}
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+ patch -p1 <"${srcdir}/giflib.patch"
+}
+
build() {
cd "${srcdir}/${_pkgname}"
./configure --prefix=/usr --with-freetype
diff --git a/giflib.patch b/giflib.patch
new file mode 100644
index 000000000000..e4881ca741fe
--- /dev/null
+++ b/giflib.patch
@@ -0,0 +1,29 @@
+--- xplanet/src/libimage/gif.c.orig 2015-07-07 11:38:14.926692910 +0200
++++ xplanet/src/libimage/gif.c 2015-07-07 12:10:07.745836346 +0200
+@@ -179,7 +179,7 @@
+ }
+ }
+
+- if (DGifCloseFile(GifFile) == GIF_ERROR) {
++ if (DGifCloseFile(GifFile, NULL) == GIF_ERROR) {
+ return(0);
+ }
+
+@@ -493,7 +493,7 @@
+ static void QuitGifError(GifFileType *GifFile)
+ {
+ fprintf(stderr, "Error writing GIF file\n");
+- if (GifFile != NULL) EGifCloseFile(GifFile);
++ if (GifFile != NULL) EGifCloseFile(GifFile, NULL);
+ }
+
+ int
+@@ -589,7 +589,7 @@
+ Ptr += width;
+ }
+
+- if (EGifCloseFile(GifFile) == GIF_ERROR)
++ if (EGifCloseFile(GifFile, NULL) == GIF_ERROR)
+
+ {
+ QuitGifError(GifFile);