summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornate2019-08-04 18:49:17 -0500
committernate2019-08-04 18:49:17 -0500
commitb60fe412b641de90ee54f4871a5b7f5a53f54d12 (patch)
tree60c2380d58fcf192c8f7a021e2a053bc6ec0965e
parent64aa9b7a891d6e4099d50521d39ad04fc8ac4b53 (diff)
downloadaur-b60fe412b641de90ee54f4871a5b7f5a53f54d12.tar.gz
xplayer 2.2.2, remove patch (fixed in linuxmint/xplayer/pull/150)
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--xplayer_issues_147.patch25
3 files changed, 7 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab92d6a686e5..ff64171f0b33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xplayer
pkgdesc = Simple media player. X-Apps Project.
- pkgver = 2.0.2
+ pkgver = 2.2.2
pkgrel = 2
url = https://github.com/linuxmint/xplayer
arch = i686
@@ -29,10 +29,8 @@ pkgbase = xplayer
optdepends = python2-xdg: Subtitle downloader plugin
provides = xplayer
conflicts = xplayer-git
- source = xplayer-2.0.2.tar.gz::https://github.com/linuxmint/xplayer/archive/2.0.2.tar.gz
- source = xplayer_issues_147.patch
- md5sums = 46526042743d6b0af60bbbb7a4388d66
- md5sums = 533653d8352f0afcac5c4542f1bc0d84
+ source = xplayer-2.2.2.tar.gz::https://github.com/linuxmint/xplayer/archive/2.2.2.tar.gz
+ md5sums = 689b108ee869a13da24afc58e7979fc6
pkgname = xplayer
diff --git a/PKGBUILD b/PKGBUILD
index c7bd93c2d012..71c36f28e99e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Nate Simon <aurpkg (at natesimon.net)>
+# Maintainer: Nate Simon <njsimon10@gmail.com>
pkgname=xplayer
-pkgver=2.0.2
+pkgver=2.2.2
pkgrel=2
pkgdesc="Simple media player. X-Apps Project."
arch=('i686' 'x86_64' 'armv7h')
@@ -20,16 +20,8 @@ provides=($pkgname)
conflicts=('xplayer-git')
url='https://github.com/linuxmint/xplayer'
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz"
- 'xplayer_issues_147.patch')
-md5sums=('46526042743d6b0af60bbbb7a4388d66'
- '533653d8352f0afcac5c4542f1bc0d84')
-
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch --strip=1 --input="${srcdir}/xplayer_issues_147.patch"
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/linuxmint/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('689b108ee869a13da24afc58e7979fc6')
build() {
diff --git a/xplayer_issues_147.patch b/xplayer_issues_147.patch
deleted file mode 100644
index 29480322a74b..000000000000
--- a/xplayer_issues_147.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 30029a515f68290f8e85f4b7344d50fce66d74f8 Mon Sep 17 00:00:00 2001
-From: DJ Sutton <dj@laptop>
-Date: Mon, 13 May 2019 17:55:23 -0600
-Subject: [PATCH] check for bvw->priv->tagcache == NULL in bacon-video-widget.c
- update_orientation_from_video
-
----
- src/backend/bacon-video-widget.c | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/src/backend/bacon-video-widget.c b/src/backend/bacon-video-widget.c
-index e95dc4b..444413c 100644
---- a/src/backend/bacon-video-widget.c
-+++ b/src/backend/bacon-video-widget.c
-@@ -1715,6 +1715,9 @@ update_orientation_from_video (BaconVideoWidget *bvw)
- if (bvw->priv->rotation != BVW_ROTATION_R_ZERO)
- return;
-
-+ if (bvw->priv->tagcache == NULL)
-+ return;
-+
- ret = gst_tag_list_get_string_index (bvw->priv->tagcache,
- GST_TAG_IMAGE_ORIENTATION, 0, &orientation_str);
- if (!ret || !orientation_str || g_str_equal (orientation_str, "rotate-0"))
-