summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:44:59 +0200
committerM0Rf302015-06-17 16:44:59 +0200
commit0111f827f0ce88055dc472a311ee25823da64eea (patch)
tree9b625c20ee1b24c0d1b8ae6b1d813ff9eb28b3f2
downloadaur-0111f827f0ce88055dc472a311ee25823da64eea.tar.gz
Initial import
-rw-r--r--.AURINFO35
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD31
-rw-r--r--xplico.install68
4 files changed, 169 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7d84f721f9e2
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,35 @@
+pkgbase = xplico
+ pkgdesc = Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = http://www.xplico.org/
+ install = xplico.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = tcpdump
+ depends = libpcap
+ depends = sqlite3
+ depends = sox
+ depends = lame
+ depends = perl
+ depends = apache
+ depends = php
+ depends = php-sqlite
+ depends = php-apache
+ depends = php-pear
+ depends = perl
+ depends = libnet
+ depends = recode
+ depends = json-c
+ depends = python-httplib2
+ depends = libmysqlclient
+ depends = ndpi
+ optdepends = geoip-citydata: City database for geoip IP location lookups
+ optdepends = ghostpdl: reconstruct document printed with network printer
+ optdepends = videosnarf: decode VoIP based on RTP
+ source = xplico::git+https://github.com/M0Rf30/xplico.git
+ md5sums = SKIP
+
+pkgname = xplico
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7d84f721f9e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+pkgbase = xplico
+ pkgdesc = Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = http://www.xplico.org/
+ install = xplico.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = tcpdump
+ depends = libpcap
+ depends = sqlite3
+ depends = sox
+ depends = lame
+ depends = perl
+ depends = apache
+ depends = php
+ depends = php-sqlite
+ depends = php-apache
+ depends = php-pear
+ depends = perl
+ depends = libnet
+ depends = recode
+ depends = json-c
+ depends = python-httplib2
+ depends = libmysqlclient
+ depends = ndpi
+ optdepends = geoip-citydata: City database for geoip IP location lookups
+ optdepends = ghostpdl: reconstruct document printed with network printer
+ optdepends = videosnarf: decode VoIP based on RTP
+ source = xplico::git+https://github.com/M0Rf30/xplico.git
+ md5sums = SKIP
+
+pkgname = xplico
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b4b6b4d85aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: M0Rf30
+pkgname=xplico
+pkgver=1.1.0
+pkgrel=2
+arch=(i686 x86_64)
+pkgdesc="Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)"
+url="http://www.xplico.org/"
+license=('GPL')
+depends=('tcpdump' 'libpcap' 'sqlite3' 'sox' 'lame' 'perl' 'apache' 'php' 'php-sqlite' 'php-apache' 'php-pear' 'perl' 'libnet' 'recode' 'json-c' 'python-httplib2' 'libmysqlclient' 'ndpi')
+optdepends=('geoip-citydata: City database for geoip IP location lookups'
+ 'ghostpdl: reconstruct document printed with network printer'
+ 'videosnarf: decode VoIP based on RTP')
+source=('xplico::git+https://github.com/M0Rf30/xplico.git')
+install=xplico.install
+
+build() {
+ cd xplico
+ make -j1
+}
+
+package() {
+ cd xplico
+ make DESTDIR=$pkgdir install
+}
+
+pkgver() {
+ cd xplico
+ echo $(git tag)
+}
+
+md5sums=('SKIP')
diff --git a/xplico.install b/xplico.install
new file mode 100644
index 000000000000..7a6b53922b87
--- /dev/null
+++ b/xplico.install
@@ -0,0 +1,68 @@
+post_install() {
+XPLICO_BASE=/opt/xplico
+DB=$XPLICO_BASE/xplico.db
+DB_OLD=$XPLICO_BASE/xplico_old.db
+DB_NEW=$XPLICO_BASE/xplico_new.db
+XI=$XPLICO_BASE/xi/app/
+XPLICO_SQLITE_BASE=$XPLICO_BASE/script/db/sqlite
+PHPINI=/etc/php/php.ini
+HTTPDCONF=/etc/httpd/conf/httpd.conf
+if grep -q '^post_max_size = 100M' $PHPINI ; then
+ echo "Variable post_max_size in $PHPINI has already been set to the recommended 100M."
+elif grep -q '^post_max_size = 8M' $PHPINI ; then
+ echo "Resetting post_max_size in $PHPINI"
+ sed --in-place '/post_max_size = 8M/s/^/post_max_size = 100M ; XPLICO /' $PHPINI
+else
+ echo "Variable post_max_size in $PHPINI is not the default (8M). Recommended value for xplico is 100M. Set by hand."
+fi
+if grep -q '^upload_max_filesize = 100M' $PHPINI ; then
+ echo "Variable upload_max_filesize in $PHPINI has already been set to the recommended 100M."
+elif grep -q '^upload_max_filesize = 2M' $PHPINI ; then
+ echo "Resetting upload max file size in $PHPINI"
+ sed --in-place '/upload_max_filesize = 2M/s/^/upload_max_filesize = 100M ; XPLICO /' $PHPINI
+else
+ echo "Variable upload_max_filesize in $PHPINI is not the default (2M). Recommended value for xplico is 100M. Set by hand."
+fi
+if grep -q '^short_open_tag = Off' $PHPINI ; then
+ echo "Setting short open tag in $PHPINI"
+ sed --in-place '/^short_open_tag = Off/s/^/short_open_tag = On ; XPLICO /' $PHPINI
+else
+ echo "Variable short_open_tag in $PHPINI is already set."
+fi
+if grep -q '^date.timezone' $PHPINI ; then
+ echo "Timezone already set in $PHPINI - no change made."
+else
+ echo "Setting timezone to US/Eastern in $PHPINI - change by hand for different time zones."
+ echo 'date.timezone = US/Eastern ; XPLICO' >> $PHPINI
+fi
+
+echo "Don't forget to enable sqlite extension in $PHPINI"
+echo "Don't forget to enable mod_rewrite module in $HTTPDCONF"
+echo "Default Xplico daemon port is 9876"
+
+mkdir -p $XI/tmp/cache/{persistent,models}
+chmod 777 -R $XI/tmp/cache/
+
+cd $XPLICO_SQLITE_BASE
+if [ -e "$DB" ]; then
+ echo "Preserving previous Xplico database"
+ mv $DB $DB_OLD
+ sh create_xplico_db.sh
+ mv $DB $DB_NEW
+ mv $DB_OLD $DB
+ sh create_xplico_db.sh
+ python3 upgrade_db.py
+ rm -f $DB_NEW
+ rm -rf /opt/xplico/xi/app/tmp/cache/models/*
+ rm -rf /opt/xplico/xi/app/tmp/cache/views/*
+else
+ echo "Creating new Xplico database"
+ sh create_xplico_db.sh
+fi
+
+}
+
+post_remove(){
+ echo "Don't forget to remove $XPLICO_BASE directory"
+ echo "Don't forget to restore php.ini and httpd.conf files"
+}