summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302019-05-26 19:11:42 +0200
committerM0Rf302019-05-26 19:11:42 +0200
commit77bd1cca67dd86e6056d80efb807c2a9c6336d3a (patch)
tree25378bccc7300d6b39ff6f18953ae8f9ef01e845
parent59b86cef74399ec63ddf77f761aef4856320d5f7 (diff)
downloadaur-77bd1cca67dd86e6056d80efb807c2a9c6336d3a.tar.gz
xplico: 1.2.2
-rw-r--r--.SRCINFO22
-rw-r--r--1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch82
-rw-r--r--PKGBUILD42
-rw-r--r--json-c.patch22
-rw-r--r--xplico.install5
5 files changed, 58 insertions, 115 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b4566351ed3..28f7e125b708 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Mon Nov 20 19:22:04 UTC 2017
pkgbase = xplico
pkgdesc = Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)
- pkgver = 1.2.1
- pkgrel = 2
+ pkgver = 1.2.2
+ pkgrel = 1
url = http://www.xplico.org/
install = xplico.install
arch = i686
@@ -12,16 +10,16 @@ pkgbase = xplico
depends = apache
depends = json-c
depends = lame
- depends = libmysqlclient
+ depends = mariadb-clients
+ depends = libmaxminddb
depends = libnet
depends = libpcap
depends = ndpi
depends = net-tools
- depends = perl
+ depends = pecl-mcrypt
depends = perl
depends = php
depends = php-apache
- depends = php-pear
depends = php-sqlite
depends = python-httplib2
depends = python-psycopg2
@@ -29,13 +27,13 @@ pkgbase = xplico
depends = sox
depends = sqlite3
depends = tcpdump
- optdepends = geoip-database-extra: City database for geoip IP location lookups
+ optdepends = geoip2-database: City database for geoip IP location lookups
optdepends = ghostpdl: reconstruct document printed with network printer
optdepends = videosnarf: decode VoIP based on RTP
- source = https://github.com/xplico/xplico/archive/v1.2.1.tar.gz
- source = 1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch
- md5sums = b16b1f1dc8520b3bbc5c3cd9439ca38a
- md5sums = 813a0ca8e13f674d3458173f90ac2e94
+ source = https://github.com/xplico/xplico/archive/v.1.2.2.tar.gz
+ source = json-c.patch
+ md5sums = 62013c924ecfd139b55e984fb95959ea
+ md5sums = 6184aa02ac099750cdc35b86dfd865e9
pkgname = xplico
diff --git a/1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch b/1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch
deleted file mode 100644
index b07479c70956..000000000000
--- a/1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch
+++ /dev/null
@@ -1,82 +0,0 @@
-From 1ed30f322b764cbb6d027775c275e4f0a5616a3f Mon Sep 17 00:00:00 2001
-From: Gianluca Costa <g.costa@xplico.org>
-Date: Sun, 30 Jul 2017 11:35:12 +0200
-Subject: [PATCH] upgrade to nDPI 2.0
-
----
- dissectors/tcp_ca/tcp_analysis.c | 4 ++--
- dissectors/tcp_grbg/tcp_garbage.c | 2 +-
- dissectors/udp_ca/udp_analysis.c | 4 ++--
- dissectors/udp_grbg/udp_garbage.c | 2 +-
- 4 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/dissectors/tcp_ca/tcp_analysis.c b/dissectors/tcp_ca/tcp_analysis.c
-index 25d2a71..e17ccc2 100644
---- a/dissectors/tcp_ca/tcp_analysis.c
-+++ b/dissectors/tcp_ca/tcp_analysis.c
-@@ -524,7 +524,7 @@ static int TcpCaDisFlow(tca_flow *ifw, packet *pkt)
- else {
- ifw->l7prot_id = nDPIPacket(pkt, ifw->l7flow, ifw->l7dst, ifw->l7src, ifw->priv.ipv6);
- }
-- if (ifw->l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (ifw->l7prot_id.app_protocol != NDPI_PROTOCOL_UNKNOWN) {
- ifw->stage++;
- ifw->l7prot_type = ndpi_protocol2name(ndpi, ifw->l7prot_id, ifw->buff, TCP_CA_LINE_MAX_SIZE);
- }
-@@ -618,7 +618,7 @@ static packet *TcpCaDisFlowEnd(tca_flow *ifw)
- else
- ifw->l7prot_id = ndpi_guess_undetected_protocol(ndpi, IPPROTO_TCP, ifw->priv.ip_s.uint32, ifw->priv.ip_d.uint32, ifw->priv.port_s, ifw->priv.port_d);
-
-- if (ifw->l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (ifw->l7prot_id.master_protocol != NDPI_PROTOCOL_UNKNOWN) {
- ifw->l7prot_type = ndpi_protocol2name(ndpi, ifw->l7prot_id, ifw->buff, TCP_CA_LINE_MAX_SIZE);
- }
- else {
-diff --git a/dissectors/tcp_grbg/tcp_garbage.c b/dissectors/tcp_grbg/tcp_garbage.c
-index 22cbddf..ad00a2f 100644
---- a/dissectors/tcp_grbg/tcp_garbage.c
-+++ b/dissectors/tcp_grbg/tcp_garbage.c
-@@ -675,7 +675,7 @@ packet *TcpGrbDissector(int flow_id)
- else {
- l7prot_id = nDPIPacket(pkt, l7flow, l7dst, l7src, ipv4);
- }
-- if (l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (l7prot_id.app_protocol != NDPI_PROTOCOL_UNKNOWN) {
- stage++;
- l7prot_type = ndpi_protocol2name(ndpi, l7prot_id, buff, TCP_CFG_LINE_MAX_SIZE);
- }
-diff --git a/dissectors/udp_ca/udp_analysis.c b/dissectors/udp_ca/udp_analysis.c
-index e270eaf..d68bc1d 100644
---- a/dissectors/udp_ca/udp_analysis.c
-+++ b/dissectors/udp_ca/udp_analysis.c
-@@ -431,7 +431,7 @@ static packet *UdpCaDissector(int flow_id)
- else {
- l7prot_id = nDPIPacket(pkt, l7flow, l7dst, l7src, ipv4);
- }
-- if (l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (l7prot_id.master_protocol != NDPI_PROTOCOL_UNKNOWN) {
- l7prot_type = ndpi_protocol2name(ndpi, l7prot_id, buff, UDP_CA_LINE_MAX_SIZE);
- }
- }
-@@ -451,7 +451,7 @@ static packet *UdpCaDissector(int flow_id)
- else
- l7prot_id = ndpi_guess_undetected_protocol(ndpi, IPPROTO_UDP, priv.ip_s.uint32, priv.ip_d.uint32, priv.port_s, priv.port_d);
-
-- if (l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (l7prot_id.master_protocol != NDPI_PROTOCOL_UNKNOWN) {
- l7prot_type = ndpi_protocol2name(ndpi, l7prot_id, buff, UDP_CA_LINE_MAX_SIZE);
- }
- else {
-diff --git a/dissectors/udp_grbg/udp_garbage.c b/dissectors/udp_grbg/udp_garbage.c
-index 0e9592b..e26fdc1 100644
---- a/dissectors/udp_grbg/udp_garbage.c
-+++ b/dissectors/udp_grbg/udp_garbage.c
-@@ -373,7 +373,7 @@ packet* UdpGrbDissector(int flow_id)
- else {
- l7prot_id = nDPIPacket(pkt, l7flow, l7dst, l7src, ipv4);
- }
-- if (l7prot_id.protocol != NDPI_PROTOCOL_UNKNOWN) {
-+ if (l7prot_id.master_protocol != NDPI_PROTOCOL_UNKNOWN) {
- l7prot_type = ndpi_protocol2name(ndpi, l7prot_id, buff, UDP_CFG_LINE_MAX_SIZE);
- }
- }
diff --git a/PKGBUILD b/PKGBUILD
index 5ac9dce2dd2c..7a92dc92a25d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: robertfoster
pkgname=xplico
-pkgver=1.2.1
-pkgrel=2
+pkgver=1.2.2
+pkgrel=1
arch=(i686 x86_64)
pkgdesc="Internet Traffic Decoder. Network Forensic Analysis Tool (NFAT)"
url="http://www.xplico.org/"
@@ -10,16 +10,16 @@ depends=(
apache
json-c
lame
- libmysqlclient
+ mariadb-clients
+ libmaxminddb
libnet
libpcap
ndpi
net-tools
- perl
+ pecl-mcrypt
perl
php
php-apache
- php-pear
php-sqlite
python-httplib2
python-psycopg2
@@ -27,27 +27,29 @@ depends=(
sox
sqlite3
tcpdump
-)
-optdepends=('geoip-database-extra: City database for geoip IP location lookups'
- 'ghostpdl: reconstruct document printed with network printer'
- 'videosnarf: decode VoIP based on RTP')
-source=("https://github.com/xplico/xplico/archive/v$pkgver.tar.gz"
- 1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch
)
+optdepends=('geoip2-database: City database for geoip IP location lookups'
+ 'ghostpdl: reconstruct document printed with network printer'
+'videosnarf: decode VoIP based on RTP')
+source=("https://github.com/xplico/xplico/archive/v.$pkgver.tar.gz"
+"json-c.patch")
install=xplico.install
+prepare() {
+ cd $pkgname-v.$pkgver
+ patch -Np1 -i ../json-c.patch
+}
+
build() {
- cd $pkgname-$pkgver
- patch -Np1 -i ../1ed30f322b764cbb6d027775c275e4f0a5616a3f.patch
- make -j1
+ cd $pkgname-v.$pkgver
+ make -j1
}
package() {
- cd $pkgname-$pkgver
- make DESTDIR=$pkgdir install
- ln -sr /usr/share/GeoIP/GeoIPCity.dat $pkgdir/opt/xplico/GeoLiteCity.dat
+ cd $pkgname-v.$pkgver
+ make DESTDIR=$pkgdir install
+ ln -sr /usr/share/GeoIP/GeoLite2-City.mmdb $pkgdir/opt/xplico/GeoLite2-City.mmdb
}
-md5sums=('b16b1f1dc8520b3bbc5c3cd9439ca38a')
-md5sums=('b16b1f1dc8520b3bbc5c3cd9439ca38a'
- '813a0ca8e13f674d3458173f90ac2e94')
+md5sums=('62013c924ecfd139b55e984fb95959ea'
+'6184aa02ac099750cdc35b86dfd865e9')
diff --git a/json-c.patch b/json-c.patch
new file mode 100644
index 000000000000..e918251f6d83
--- /dev/null
+++ b/json-c.patch
@@ -0,0 +1,22 @@
+--- a/manipulators/mwebymsg/analyse.c 2019-05-26 18:38:15.722151286 +0200
++++ b/ manipulators/mwebymsg/analyse.c 2019-05-26 18:38:37.785856970 +0200
+@@ -24,6 +24,8 @@
+ */
+
+ #define _GNU_SOURCE
++#define JSON_C_VER_013 (13 << 8)
++
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
+@@ -32,8 +34,9 @@
+ #include <signal.h>
+ #include <unistd.h>
+ #include <json-c/json.h>
++#if (!defined(JSON_C_VERSION_NUM)) || (JSON_C_VERSION_NUM < JSON_C_VER_013)
+ #include <json-c/json_object_private.h>
+-
++#endif
+ #include "log.h"
+ #include "analyse.h"
+ #include "proto.h"
diff --git a/xplico.install b/xplico.install
index 56c884b35ed5..538bab55a19c 100644
--- a/xplico.install
+++ b/xplico.install
@@ -6,9 +6,12 @@ DB_NEW=$XPLICO_BASE/xplico_new.db
XI=$XPLICO_BASE/xi/app/
XPLICO_SQLITE_BASE=$XPLICO_BASE/script/db/sqlite
PHPINI=/etc/php/php.ini
+PHPINIEXTRA=/etch/php/conf.d/3-mcrypt.ini
HTTPDCONF=/etc/httpd/conf/httpd.conf
-echo "Don't forget to enable sqlite extension in $PHPINI"
+echo "Don't forget to enable sqlite3 extension in $PHPINI"
+echo "Don't forget to enable pdo_sqlite extension in $PHPINI"
+echo "Don't forget to enable mcrypt extension in $PHPINIEXRA"
echo "Don't forget to enable mod_rewrite module in $HTTPDCONF"
echo "Default Xplico daemon port is 9876"