summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 17:24:56 +0800
committerzxp198210052023-12-20 17:24:56 +0800
commite910199d76ad28b10c9492a90811b6a1f5953a0c (patch)
tree7162da773c682d25129b3f99ae3a2a4bd4c5c99d
parent63b18a393f0a6eb29a47310b142d6d42b529a155 (diff)
downloadaur-e910199d76ad28b10c9492a90811b6a1f5953a0c.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
-rw-r--r--xplist.sh10
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcd15b4f7fcb..6e5b20c03883 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,8 +16,10 @@ pkgbase = xplist-bin
conflicts = xplist
options = !strip
source = xplist-1.2.47.AppImage::https://github.com/ic005k/Xplist/releases/download/1.2.47/Xplist-Linux-x86_64.AppImage
- source = LICENSE::https://raw.githubusercontent.com/ic005k/Xplist/1.2.47/LICENSE
+ source = LICENSE-1.2.47::https://raw.githubusercontent.com/ic005k/Xplist/1.2.47/LICENSE
+ source = xplist.sh
sha256sums = 9319fd1f4ccda8abe34ab18390f3cd81d69c442c5030f7583e59c8bc4c1395eb
sha256sums = 3515a1c9e2ce8df51e80f0a03a0ffca92430c7dca6989ff20b16031d676a652b
+ sha256sums = 12e9126d4957037d74b22293a0afd683a88e6fd72f82626128291bc5cedf50ee
pkgname = xplist-bin
diff --git a/PKGBUILD b/PKGBUILD
index 06578b1251d9..62abeb108bff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,20 +21,25 @@ depends=(
)
source=(
"${pkgname%-bin}-${pkgver}.AppImage::${url}/releases/download/${pkgver}/${_pkgname}-Linux-${CARCH}.AppImage"
- "LICENSE::https://raw.githubusercontent.com/ic005k/Xplist/${pkgver}/LICENSE"
+ "LICENSE-${pkgver}::https://raw.githubusercontent.com/ic005k/Xplist/${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
)
sha256sums=('9319fd1f4ccda8abe34ab18390f3cd81d69c442c5030f7583e59c8bc4c1395eb'
- '3515a1c9e2ce8df51e80f0a03a0ffca92430c7dca6989ff20b16031d676a652b')
+ '3515a1c9e2ce8df51e80f0a03a0ffca92430c7dca6989ff20b16031d676a652b'
+ '12e9126d4957037d74b22293a0afd683a88e6fd72f82626128291bc5cedf50ee')
build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${_pkgname}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
sed "s|AppRun|${pkgname%-bin}|g;s|icon|${pkgname%-bin}|g;s|Application;|Utility;|g" -i "${srcdir}/squashfs-root/default.desktop"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt/"${pkgname%-bin}",usr/bin}
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 -d "${pkgdir}/opt/${pkgname%-bin}"
cp -r "${srcdir}/squashfs-root/"* "${pkgdir}/opt/${pkgname%-bin}"
- ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
install -Dm644 "${srcdir}/squashfs-root/default.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/icon.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/LICENSE-${pkgver}" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/xplist.sh b/xplist.sh
new file mode 100644
index 000000000000..34f67a19eb14
--- /dev/null
+++ b/xplist.sh
@@ -0,0 +1,10 @@
+#!/bin/sh
+set -e
+_APPDIR="/opt/@appname@"
+_RUNAPP="${_APPDIR}/@runname@"
+export PATH="${_APPDIR}:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
+export QT_PLUGIN_PATH="${_APPDIR}/plugins:${QT_PLUGIN_PATH}"
+cd "${_APPDIR}"
+exec "${_RUNAPP}" "$@"
+exit \ No newline at end of file