summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2018-05-07 14:04:48 +0200
committerTomasz Żok2018-05-07 14:04:48 +0200
commit654bb0525663fe378e61a788ceeff2a0ad29df3a (patch)
tree065a29b5d5be25caa1a1b1199e4d383f930f4d82
parent25324f62d89cde3609742725b5a3bd7f38d564c8 (diff)
downloadaur-654bb0525663fe378e61a788ceeff2a0ad29df3a.tar.gz
Update to 2.48
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD24
-rw-r--r--xplor-nih.install10
-rw-r--r--xplor-nih.md54
4 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 259af8225609..b64b3a7caa19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = xplor-nih
pkgdesc = XPLOR-NIH is a structure determination program which builds on the X-PLOR program, including additional tools developed at the NIH
- pkgver = 2.47
+ pkgver = 2.48
pkgrel = 1
url = https://nmr.cit.nih.gov/xplor-nih/
- install = xplor-nih.install
arch = x86_64
license = custom
depends = ncurses5-compat-libs
+ options = !strip
source = LICENSE
source = xplor-nih.md5
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index a7fc5011edcc..4e001c396b25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
pkgname=xplor-nih
-pkgver=2.47
+pkgver=2.48
pkgrel=1
pkgdesc="XPLOR-NIH is a structure determination program which builds on the X-PLOR program, including additional tools developed at the NIH"
arch=('x86_64')
url="https://nmr.cit.nih.gov/xplor-nih/"
license=('custom')
-install=${pkgname}.install
-depends=(ncurses5-compat-libs)
+depends=('ncurses5-compat-libs')
source=('LICENSE'
"${pkgname}.md5")
md5sums=('SKIP'
'SKIP')
+options=('!strip')
prepare() {
if [[ ! -r "../${pkgname}-${pkgver}-db.tar.gz" || ! -r "../${pkgname}-${pkgver}-Linux_x86_64.tar.gz" ]]; then
@@ -25,13 +25,25 @@ prepare() {
bsdtar xfz ../${pkgname}-${pkgver}-db.tar.gz
bsdtar xfz ../${pkgname}-${pkgver}-Linux_x86_64.tar.gz
+
+ sed -i "s|pwd=\`pwd\`|pwd=/opt/${pkgname}-${pkgver}|" "${pkgname}-${pkgver}/configure"
+ sed -i "s|XPLOR_DIR=__XPLOR_DIR__|XPLOR_DIR=$(pwd)/${pkgname}-${pkgver}|" "${pkgname}-${pkgver}/bin/xplor.in"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ ./configure -symlinks symlinks/
+
+ # revert change from prepare()
+ sed -i "s|^XPLOR_DIR=.*$|XPLOR_DIR=/opt/${pkgname}-${pkgver}|" "bin/xplor"
}
package() {
- install -d "${pkgdir}/etc/profile.d/"
+ install -D -t "${pkgdir}/usr/bin/" ${pkgname}-${pkgver}/symlinks/*
+ find ${pkgname}-${pkgver}/symlinks/ -delete
+
install -d "${pkgdir}/opt/"
+ cp -R "${pkgname}-${pkgver}" "${pkgdir}/opt/"
- echo "export PATH=\$PATH:/opt/${pkgname}-${pkgver}/bin:/opt/${pkgname}-${pkgver}/bin.Linux_x86_64" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
- cp -R "${pkgname}-${pkgver}" "${pkgdir}/opt/"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/xplor-nih.install b/xplor-nih.install
deleted file mode 100644
index 65a9551d2101..000000000000
--- a/xplor-nih.install
+++ /dev/null
@@ -1,10 +0,0 @@
-post_install() {
- echo 'Running post-install / post-upgrade configuration'
- pkgver=${1%-*}
- cd /opt/xplor-nih-${pkgver}
- ./configure
-}
-
-post_upgrade() {
- post_install $@
-}
diff --git a/xplor-nih.md5 b/xplor-nih.md5
index b3a722c32f67..17db74e935be 100644
--- a/xplor-nih.md5
+++ b/xplor-nih.md5
@@ -1,2 +1,2 @@
-d54cf3d8f7bb915bb7f2c5472669cc1e ../xplor-nih-2.47-Linux_x86_64.tar.gz
-416fc7e5b44a945085937baffcfa21c0 ../xplor-nih-2.47-db.tar.gz
+af65196a20c1d518c010b63878d09584 ../xplor-nih-2.48-Linux_x86_64.tar.gz
+4cf7ccd2d68f3d12a05052d3cc41b7c9 ../xplor-nih-2.48-db.tar.gz