summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTomasz Żok2016-04-15 16:17:28 +0200
committerTomasz Żok2016-04-15 16:17:28 +0200
commitb8ab30dcd80ff86fb44a7e9d644dcd39f0822d77 (patch)
tree47f3242dd9259ed0bcb4ad48fe81c16576c47bfc
downloadaur-b8ab30dcd80ff86fb44a7e9d644dcd39f0822d77.tar.gz
Initial version of XPLOR-NIH package
-rw-r--r--.SRCINFO13
-rw-r--r--LICENSE36
-rw-r--r--PKGBUILD30
-rw-r--r--xplor-nih.install10
4 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f44de8f163dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = xplor-nih
+ pkgdesc = XPLOR-NIH is a structure determination program which builds on the X-PLOR program, including additional tools developed at the NIH
+ pkgver = 2.41.1
+ pkgrel = 1
+ url = https://nmr.cit.nih.gov/xplor-nih/
+ install = xplor-nih.install
+ arch = x86_64
+ license = custom
+ source = LICENSE
+ md5sums = de4f34dc4d9738669b57850f7ef77a71
+
+pkgname = xplor-nih
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..54cc25539d89
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,36 @@
+ LICENSE FOR NON-PROFIT INSTITUTIONS TO USE XPLOR-NIH
+
+ Terms of Agreement
+
+By downloading or using the Xplor-NIH software you agree to the
+following terms:
+
+- You shall not use the software for any purpose (research or
+ otherwise) that is supported by a "for profit" organization without
+ prior written authorization.
+
+- You agree that the software is furnished on an "as is" basis and
+ that the authors in no way warrant the software or any of its
+ results and is in no way liable for any use you make of the software.
+
+- Ownership of software and documentation is retained by the
+ appropriate, respective organizations.
+
+- You shall not disclose in any form either the delivered software or
+ documentation to third parties without prior written authorization.
+
+
+In addition, we request that you adhere to the following practices:
+
+- Please report modifications and additions to the software back to
+ the Xplor-NIH authors. We would like the modified source code and a
+ test script, such that we can include the modifications in future
+ versions of the software.
+
+- In reports or publication of results obtained using Xplor-NIH,
+ please acknowledge use of the software by citing the article:
+
+
+ C.D. Schwieters, J.J. Kuszewski, N. Tjandra, G.M. Clore, ``The
+ Xplor-NIH NMR Molecular Structure Determination Package,''
+ J. Magn. Res., 160, 66-74 (2003).
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..795805c52a0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tomasz Zok <tomasz.zok [at] gmail.com>
+pkgname=xplor-nih
+pkgver=2.41.1
+pkgrel=1
+pkgdesc="XPLOR-NIH is a structure determination program which builds on the X-PLOR program, including additional tools developed at the NIH"
+arch=('x86_64')
+url="https://nmr.cit.nih.gov/xplor-nih/"
+license=('custom')
+install=${pkgname}.install
+source=("LICENSE")
+md5sums=('de4f34dc4d9738669b57850f7ef77a71')
+
+prepare() {
+ if [[ ! -r "../${pkgname}-${pkgver}-db.tar.gz" || ! -r "../${pkgname}-${pkgver}-Linux_x86_64.tar.gz" ]]; then
+ echo "You must download XPLOR-NIH on your own from the project webpage: ${pkgname}-${pkgver}-db.tar.gz and ${pkgname}-${pkgver}-Linux_x86_64.tar.gz"
+ return 1
+ fi
+
+ bsdtar xfz ../${pkgname}-${pkgver}-db.tar.gz
+ bsdtar xfz ../${pkgname}-${pkgver}-Linux_x86_64.tar.gz
+}
+
+package() {
+ install -d "${pkgdir}/etc/profile.d/"
+ install -d "${pkgdir}/opt/"
+
+ echo "export PATH=\$PATH:/opt/${pkgname}-${pkgver}/bin:/opt/${pkgname}-${pkgver}/bin.Linux_x86_64" > "${pkgdir}/etc/profile.d/${pkgname}.sh"
+ cp -R "${pkgname}-${pkgver}" "${pkgdir}/opt/"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/xplor-nih.install b/xplor-nih.install
new file mode 100644
index 000000000000..65a9551d2101
--- /dev/null
+++ b/xplor-nih.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo 'Running post-install / post-upgrade configuration'
+ pkgver=${1%-*}
+ cd /opt/xplor-nih-${pkgver}
+ ./configure
+}
+
+post_upgrade() {
+ post_install $@
+}