summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu Westphal2016-07-10 20:36:33 +0200
committerMathieu Westphal2016-07-10 20:38:01 +0200
commit14cd237b481ca6beffe23ba344e9db8b488eab30 (patch)
tree92311d844a4bc4b53b089e51e12f8ab9e2608f00
downloadaur-xplorers.tar.gz
Initial Commit for xplorers
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD44
-rw-r--r--xplorers.sh24
3 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc01aad91012
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = xplorers
+ pkgdesc = Xplorers Board game
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://games.asobrain.com/
+ arch = any
+ license = Other
+ depends = icedtea-web
+ source = xplorersCities1.jnlp::file://xplorersCities1.jnlp
+ source = xplorersBasic1.jnlp::file://xplorersBasic1.jnlp
+ source = xplorersPractice1.jnlp::file://xplorersPractice1.jnlp
+ source = xplorersPractice2.jnlp::file://xplorersPractice2.jnlp
+ source = xplorersTeam1.jnlp::file://xplorersTeam1.jnlp
+ source = xplorersTournament1.jnlp::file://xplorersTournament1.jnlp
+ source = xplorersTournament2.jnlp::file://xplorersTournament2.jnlp
+ source = xplorersTournament3.jnlp::file://xplorersTournament3.jnlp
+ source = xplorers.sh
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = e7bb46f10f60e1aa4917d60bd9c4104f
+
+pkgname = xplorers
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4942038a7f17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Author: Mathieu Westphal <mathieu.westphal@gmail.com>
+
+pkgname=xplorers
+pkgver=1.0
+pkgrel=1
+pkgdesc="Xplorers Board game"
+arch=('any')
+url="http://games.asobrain.com/"
+license=(Other)
+depends=('icedtea-web')
+source=(
+ "${pkgname}Cities1.jnlp::file://${pkgname}Cities1.jnlp"
+ "${pkgname}Basic1.jnlp::file://${pkgname}Basic1.jnlp"
+ "${pkgname}Practice1.jnlp::file://${pkgname}Practice1.jnlp"
+ "${pkgname}Practice2.jnlp::file://${pkgname}Practice2.jnlp"
+ "${pkgname}Team1.jnlp::file://${pkgname}Team1.jnlp"
+ "${pkgname}Tournament1.jnlp::file://${pkgname}Tournament1.jnlp"
+ "${pkgname}Tournament2.jnlp::file://${pkgname}Tournament2.jnlp"
+ "${pkgname}Tournament3.jnlp::file://${pkgname}Tournament3.jnlp"
+ "${pkgname}.sh"
+ )
+
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'e7bb46f10f60e1aa4917d60bd9c4104f')
+
+package() {
+
+ # Install .jnlp files
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp "${srcdir}/"*".jnlp" "${pkgdir}/opt/${pkgname}"
+
+ # install launcher script
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xplorers.sh b/xplorers.sh
new file mode 100644
index 000000000000..008d0c5744ab
--- /dev/null
+++ b/xplorers.sh
@@ -0,0 +1,24 @@
+#!/bin/bash
+# Use -gt 1 to consume two arguments per pass in the loop (e.g. each
+# argument has a corresponding value to go with it).
+# Use -gt 0 to consume one or more arguments per pass in the loop (e.g.
+# some arguments don't have a corresponding value to go with it such
+# as in the --default example).
+# note: if this is set to -gt 0 the /etc/hosts part is not recognized ( may be a bug )
+while [[ $# -gt 1 ]]
+do
+key="$1"
+
+case $key in
+ -s|--server)
+ SERVER="$2"
+ shift # past argument
+ ;;
+esac
+shift # past argument or value
+done
+if [ -z "${SERVER}" ]; then
+ SERVER="Cities1"
+fi
+echo SERVER = "${SERVER}"
+javaws /opt/xplorers/xplorers${SERVER}.jnlp