summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2021-04-05 18:04:57 +0300
committerorhun2021-04-05 18:04:57 +0300
commit84436c410fc451ffac2026454e15f6ed1f6fe354 (patch)
tree35b212bfc99e84b5531150f8a11ff42b2f7df2ef
downloadaur-84436c410fc451ffac2026454e15f6ed1f6fe354.tar.gz
Initial upload: xplr-git 0.3.0.r0.g981ead8-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD38
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bb21476e55b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xplr-git
+ pkgdesc = A hackable, minimal, fast TUI file explorer (git)
+ pkgver = 0.3.0.r0.g981ead8
+ pkgrel = 1
+ url = https://github.com/sayanarijit/xplr
+ arch = x86_64
+ license = MIT
+ makedepends = rust
+ makedepends = git
+ depends = gcc-libs
+ provides = xplr
+ conflicts = xplr
+ source = git+https://github.com/sayanarijit/xplr
+ sha512sums = SKIP
+
+pkgname = xplr-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0ed0dde3731
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=xplr-git
+pkgver=0.3.0.r0.g981ead8
+pkgrel=1
+pkgdesc="A hackable, minimal, fast TUI file explorer (git)"
+arch=('x86_64')
+url="https://github.com/sayanarijit/xplr"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('rust' 'git')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=("git+${url}")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname%-git}"
+ cargo build --locked --release
+}
+
+check() {
+ cd "${pkgname%-git}"
+ cargo test --locked --release
+}
+
+package() {
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}