summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbug2020-06-05 11:01:09 +0300
committerbug2020-06-05 11:01:09 +0300
commit64a1f251e8dd88376f9d866cb187963477732bf2 (patch)
treed9601d609dcd6c1db9d10f6dec554a0ba441fff5
parent17955eb2961ad51bfa409bd555ddb993df9e6caa (diff)
downloadaur-64a1f251e8dd88376f9d866cb187963477732bf2.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO37
-rw-r--r--PKGBUILD26
2 files changed, 29 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d64f29f3a04e..a6bfe90f6635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,36 @@
-# Generated by mksrcinfo v8
-# Tue Apr 9 12:18:36 UTC 2019
pkgbase = xpra-svn
pkgdesc = multi-platform screen and application forwarding system screen for X11
- pkgver = r22367
+ pkgver = r26625
pkgrel = 1
url = https://www.xpra.org
arch = x86_64
license = GPL2
makedepends = subversion
- makedepends = python2-setuptools
- makedepends = cython2
+ makedepends = python-setuptools
+ makedepends = cython
makedepends = uglify-js
- depends = python2
- depends = pygtk
+ depends = gtk3
+ depends = python
depends = libxtst
- depends = python2-pillow
- depends = python2-lz4
+ depends = python-cairo
+ depends = python-gobject
+ depends = python-pillow
+ depends = python-lz4
depends = ffmpeg
depends = libvpx
depends = xf86-video-dummy
depends = libxkbfile
- depends = python2-netifaces
- depends = python2-numpy
- depends = python2-rencode
- depends = python2-opengl
- depends = python2-gtkglext
- depends = python-lz4
+ depends = python-netifaces
+ depends = python-rencode
depends = python-opengl
+ depends = python-lz4
optdepends = x264: Codec
- optdepends = python2-dbus: dbus features
- optdepends = python2-pycups: Printing support
- optdepends = python2-cryptography: Cryptography
+ optdepends = python-dbus: dbus features
+ optdepends = python-pycups: Printing support
optdepends = python-cryptography: Cryptography
- optdepends = gst-python2: Sound Forwarding
- optdepends = opencv: Webcam Capture
+ optdepends = python-numpy: GPU accelerated capture and compression for NVIDIA cards
+ optdepends = gst-python: Sound Forwarding
+ optdepends = opencv: Webcam Forwarding
provides = xpra
conflicts = xpra
backup = etc/xpra/xpra.conf
diff --git a/PKGBUILD b/PKGBUILD
index b522a4c685bc..18f47483b351 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,25 @@
# Contributor: Bug <bug2000@gmail.com>
# Maintainer: Bug <bug2000@gmail.com>
pkgname=xpra-svn
-pkgver=r22367
+pkgver=r26625
pkgrel=1
pkgdesc="multi-platform screen and application forwarding system screen for X11"
arch=('x86_64')
url='https://www.xpra.org'
license=('GPL2')
-depends=('python2' 'pygtk' 'libxtst' 'python2-pillow' 'python2-lz4'
+depends=('gtk3' 'python' 'libxtst' 'python-cairo' 'python-gobject' 'python-pillow' 'python-lz4'
'ffmpeg' 'libvpx' 'xf86-video-dummy' 'libxkbfile'
- 'python2-netifaces' 'python2-numpy' 'python2-rencode' 'python2-opengl'
- 'python2-gtkglext' 'python-lz4' 'python-opengl')
-optdepends=('x264: Codec' 'python2-dbus: dbus features'
- 'python2-pycups: Printing support'
- 'python2-cryptography: Cryptography'
+ 'python-netifaces' 'python-rencode' 'python-opengl'
+ 'python-lz4')
+optdepends=('x264: Codec' 'python-dbus: dbus features'
+ 'python-pycups: Printing support'
'python-cryptography: Cryptography'
- 'gst-python2: Sound Forwarding'
- 'opencv: Webcam Capture')
+ 'python-numpy: GPU accelerated capture and compression for NVIDIA cards'
+ 'gst-python: Sound Forwarding'
+ 'opencv: Webcam Forwarding')
conflicts=('xpra')
provides=('xpra')
-makedepends=('subversion' 'python2-setuptools' 'cython2' 'uglify-js')
+makedepends=('subversion' 'python-setuptools' 'cython' 'uglify-js')
backup=('etc/xpra/xpra.conf' 'etc/xpra/xorg.conf'
'etc/xpra/conf.d/05_features.conf'
'etc/xpra/conf.d/10_network.conf'
@@ -47,14 +47,12 @@ pkgver() {
build() {
cd "${srcdir}/${pkgname%-svn}"
-
- export pkgdir
- python2 setup.py build --without-enc_x265
+ python setup.py build
}
package() {
cd "${srcdir}/${pkgname%-svn}"
- python2 setup.py install --root="${pkgdir}" --optimize=1 --skip-build --without-enc_x265
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
sed -i 's|/build/xpra/pkg/xpra/etc/xpra/xorg.conf|/etc/xpra/xorg.conf|' "${pkgdir}"/etc/xpra/conf.d/55_server_x11.conf
mv "${pkgdir}"/lib/* "${pkgdir}"/usr/lib/
rmdir "${pkgdir}/lib"