summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-11-13 16:35:29 +0100
committeranthraxx2016-11-13 16:35:29 +0100
commit643c68c2e7997e30b791c71f489eca481bd0280f (patch)
treef54b727c1180840ba92f109fa01ac627d0df6871
parent1a0503380c5a232a86caed090b0296463b4ce324 (diff)
downloadaur-643c68c2e7997e30b791c71f489eca481bd0280f.tar.gz
upgpkg: xprobe2 0.3-3
-rw-r--r--.SRCINFO16
-rwxr-xr-xPKGBUILD48
-rw-r--r--fix-for-gcc4.3.patch35
-rwxr-xr-xip.patch10
-rwxr-xr-xmisc.patch9
-rw-r--r--reproducible_build.patch49
-rwxr-xr-xtcp.patch10
7 files changed, 125 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc8420f76d8c..54459de3275b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = xprobe2
- pkgdesc = xprobe2 is an active OS fingerprinting tool
+ pkgdesc = Active OS fingerprinting tool
pkgver = 0.3
- pkgrel = 2
- url = http://sourceforge.net/apps/mediawiki/xprobe/index.php?title=Main_Page
+ pkgrel = 3
+ url = https://sourceforge.net/projects/xprobe/
arch = i686
arch = x86_64
license = GPL2
- depends = gcc
depends = libpcap
- source = http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2%200.3/xprobe2-0.3.tar.gz
- md5sums = 3ebb89ed9380038d368327816e34ec54
+ backup = etc/xprobe2/xprobe2.conf
+ source = http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2 0.3/xprobe2-0.3.tar.gz
+ source = fix-for-gcc4.3.patch
+ source = reproducible_build.patch
+ sha512sums = fd499ada22be5df3e01630948cb72d1a9e648e0c7bfaf2a688386a61c67bb36a326a9e2f3f2b9960a6a49128343010aafe8a3f04ec05e89420a1384215e41f21
+ sha512sums = 50fe71183e9717af0fcce97ecc2971b5be7024f07cb7acb5d019bf07d6549382936c8c6db860d18639e555263907654e1852054670cb3df5b618d62a1f47858b
+ sha512sums = 1ade43894b078521f16bf7609af551455211eb1b2e4c571bf23639abb530391f2474ad49f3a2f52c0298344691faa0e18250909d04b30156d5e2732df29399c5
pkgname = xprobe2
diff --git a/PKGBUILD b/PKGBUILD
index 2b47b82a7858..d343af01a416 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,41 @@
-# Maintainer: sandman <r.coded@gmail.com>
+# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
+# Contributor: sandman <r.coded@gmail.com>
# Contributor: Christoph Siegenthaler <csi@gmx.ch>
pkgname=xprobe2
pkgver=0.3
-pkgrel=2
-pkgdesc="xprobe2 is an active OS fingerprinting tool"
-url="http://sourceforge.net/apps/mediawiki/xprobe/index.php?title=Main_Page"
-depends=('gcc' 'libpcap')
-source=('http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2%200.3/'$pkgname'-'$pkgver'.tar.gz')
-md5sums=('3ebb89ed9380038d368327816e34ec54')
+pkgrel=3
+pkgdesc='Active OS fingerprinting tool'
arch=('i686' 'x86_64')
license=('GPL2')
+url='https://sourceforge.net/projects/xprobe/'
+backup=('etc/xprobe2/xprobe2.conf')
+depends=('libpcap')
+source=("http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2 ${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ fix-for-gcc4.3.patch
+ reproducible_build.patch)
+sha512sums=('fd499ada22be5df3e01630948cb72d1a9e648e0c7bfaf2a688386a61c67bb36a326a9e2f3f2b9960a6a49128343010aafe8a3f04ec05e89420a1384215e41f21'
+ '50fe71183e9717af0fcce97ecc2971b5be7024f07cb7acb5d019bf07d6549382936c8c6db860d18639e555263907654e1852054670cb3df5b618d62a1f47858b'
+ '1ade43894b078521f16bf7609af551455211eb1b2e4c571bf23639abb530391f2474ad49f3a2f52c0298344691faa0e18250909d04b30156d5e2732df29399c5')
+
+prepare(){
+ cd ${pkgname}-${pkgver}
+ patch -p1 < "${srcdir}/fix-for-gcc4.3.patch"
+ patch -p1 < "${srcdir}/reproducible_build.patch"
+}
+
build(){
- cd $startdir
- patch -p1 < ip.patch
- patch -p1 < misc.patch
- patch -p1 < tcp.patch
- cd $startdir/src/$pkgname-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc
- make || return 1
+ cd ${pkgname}-${pkgver}
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc
+ make
}
package(){
- cd $startdir/src/$pkgname-$pkgver
- make DESTDIR=$startdir/pkg install
-} \ No newline at end of file
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/fix-for-gcc4.3.patch b/fix-for-gcc4.3.patch
new file mode 100644
index 000000000000..3e445337d6b9
--- /dev/null
+++ b/fix-for-gcc4.3.patch
@@ -0,0 +1,35 @@
+Description: Fix FTBFS with gcc 4.3
+Author: Luk Claes <luk@debian.org>
+Bug-Debian: https://bugs.debian.org/417779
+Last-Update: 2016-03-15
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/libs-external/USI++/src/ip.cc
++++ b/libs-external/USI++/src/ip.cc
+@@ -13,6 +13,7 @@
+ #include "usi++/ip.h"
+
+ #include "config.h"
++#include <cstdlib>
+ #include <iostream>
+ #include <string.h>
+ #include <errno.h>
+--- a/libs-external/USI++/src/misc.cc
++++ b/libs-external/USI++/src/misc.cc
+@@ -1,5 +1,6 @@
+ #include "usi++/usi++"
+ #include "usi++/usi-structs.h"
++#include <cstdlib>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+--- a/libs-external/USI++/usi++/tcp.h
++++ b/libs-external/USI++/usi++/tcp.h
+@@ -15,6 +15,7 @@
+ #include "usi-structs.h"
+ #include "datalink.h"
+ #include "ip.h"
++#include <cstring>
+
+ namespace usipp {
+
diff --git a/ip.patch b/ip.patch
deleted file mode 100755
index faa37b04e831..000000000000
--- a/ip.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- old/src/xprobe2-0.3/libs-external/USI++/src/ip.cc 2005-07-27 14:08:15.000000000 +0530
-+++ new/src/xprobe2-0.3/libs-external/USI++/src/ip.cc 2011-02-13 09:44:58.997511172 +0530
-@@ -13,6 +13,7 @@
- #include "usi++/ip.h"
-
- #include "config.h"
-+#include <cstdlib>
- #include <iostream>
- #include <string.h>
- #include <errno.h>
diff --git a/misc.patch b/misc.patch
deleted file mode 100755
index e89fc4378608..000000000000
--- a/misc.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- old/src/xprobe2-0.3/libs-external/USI++/src/misc.cc 2005-07-27 14:08:15.000000000 +0530
-+++ new/src/xprobe2-0.3/libs-external/USI++/src/misc.cc 2011-02-13 09:50:31.033661585 +0530
-@@ -1,5 +1,6 @@
- #include "usi++/usi++"
- #include "usi++/usi-structs.h"
-+#include <cstdlib>
- #include <string.h>
- #include <unistd.h>
- #include <sys/ioctl.h>
diff --git a/reproducible_build.patch b/reproducible_build.patch
new file mode 100644
index 000000000000..fa353a085322
--- /dev/null
+++ b/reproducible_build.patch
@@ -0,0 +1,49 @@
+Author: Reiner Herrmann <reiner@reiner-h.de>
+Description: Sort order of object files in static libraries
+
+--- a/libs-external/USI++/src/Makefile.in
++++ b/libs-external/USI++/src/Makefile.in
+@@ -15,7 +15,7 @@
+ clear
+
+ usi++:icmp.o datalink.o ip.o misc.o udp.o tcp.o TX_IP.o Layer2.o arp.o
+- ar cr libusi++.a *.o
++ ar cr libusi++.a `LC_ALL=C ls *.o`
+ # ld *.o -Bshareable -o libusi++.so
+ $(RANLIB) libusi++.a
+ rm -f *.o
+--- a/src/xpmodules/alive_probe/Makefile.in
++++ b/src/xpmodules/alive_probe/Makefile.in
+@@ -42,7 +42,7 @@
+ all: alive_probe.a
+
+ alive_probe.a: icmp_ping.o tcp_ping.o udp_ping.o ttl_module portscan_module
+- ar cr alive_probe.a *.o ttl_calc/*.o portscanner/*.o
++ ar cr alive_probe.a `LC_ALL=C ls *.o ttl_calc/*.o portscanner/*.o`
+ $(RANLIB) alive_probe.a
+
+ icmp_ping.o: icmp_ping.cc
+--- a/src/xpmodules/os_probe/Makefile.in
++++ b/src/xpmodules/os_probe/Makefile.in
+@@ -43,8 +43,8 @@
+
+ os_probe.a: icmp_port_unreach_mod icmp_echo_id_mod icmp_timestamp_mod \
+ icmp_inforeq_mod icmp_addrmask_mod tcp_handshake_mod tcp_rst_mod smb_mod snmp_mod
+- ar cr os_probe.a icmp_port_unreach/*.o icmp_echo_id/*.o icmp_timestamp/*.o \
+- icmp_inforeq/*.o icmp_addrmask/*.o tcp_handshake/*.o tcp_rst/*.o smb/*.o snmp/*.o
++ ar cr os_probe.a `LC_ALL=C ls icmp_port_unreach/*.o icmp_echo_id/*.o icmp_timestamp/*.o \
++ icmp_inforeq/*.o icmp_addrmask/*.o tcp_handshake/*.o tcp_rst/*.o smb/*.o snmp/*.o`
+ $(RANLIB) os_probe.a
+
+
+--- a/src/xplib/Makefile.in
++++ b/src/xplib/Makefile.in
+@@ -44,7 +44,7 @@
+ all: libxplib.a
+
+ libxplib.a: $(OBJS)
+- ar cr libxplib.a *.o
++ ar cr libxplib.a `LC_ALL=C ls *.o`
+ $(RANLIB) libxplib.a
+
+ .c.o: $(INCLUDES)
diff --git a/tcp.patch b/tcp.patch
deleted file mode 100755
index 268c25baf042..000000000000
--- a/tcp.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- old/src/xprobe2-0.3/libs-external/USI++/usi++/tcp.h 2005-07-27 14:08:14.000000000 +0530
-+++ new/src/xprobe2-0.3/libs-external/USI++/usi++/tcp.h 2011-02-13 09:51:12.697355342 +0530
-@@ -15,6 +15,7 @@
- #include "usi-structs.h"
- #include "datalink.h"
- #include "ip.h"
-+#include <cstring>
-
- namespace usipp {
-