summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDet2015-06-14 04:13:28 +0300
committerDet2015-06-14 04:14:16 +0300
commit052e3b241a291d6157aee85a20284fe519c364d9 (patch)
treefdb2979656bdffabd820115f6fa58b0528c079e2
downloadaur-052e3b241a291d6157aee85a20284fe519c364d9.tar.gz
Initial import: 7.0.27.1.r246.g70cf8ac-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD42
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..601f8797731d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xproto-git
+ pkgdesc = X11 core wire protocol and auxiliary headers - Git version
+ pkgver = 7.0.27.1.r246.g70cf8ac
+ pkgrel = 1
+ url = http://cgit.freedesktop.org/xorg/proto/xproto/
+ arch = any
+ license = custom
+ makedepends = git
+ makedepends = xorg-util-macros
+ provides = xproto=7.0.27.1.r246.g70cf8ac
+ conflicts = xproto
+ source = git://anongit.freedesktop.org/xorg/proto/xproto
+ md5sums = SKIP
+
+pkgname = xproto-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca8c7f5aaef0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Det <nimetonmaili g-mail>
+# Contributor: Matt Parnell/ilikenwf <parwok@gmail.com>
+# Based on [extra]'s xproto: https://projects.archlinux.org/svntogit/packages.git/tree/trunk?h=packages/xproto
+
+_pkgname=xproto
+pkgname=$_pkgname-git
+pkgver=7.0.27.1.r246.g70cf8ac
+pkgrel=1
+pkgdesc="X11 core wire protocol and auxiliary headers - Git version"
+arch=('any')
+url="http://cgit.freedesktop.org/xorg/proto/$_pkgname/"
+license=('custom')
+makedepends=('git' 'xorg-util-macros')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("git://anongit.freedesktop.org/xorg/proto/$_pkgname")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+
+ echo $(git describe --long | cut -d "-" -f2-3 | tr - .).r$(git rev-list HEAD --count).$(git describe --long | cut -d "-" -f4)
+}
+
+build() {
+ cd $_pkgname
+
+ msg2 "Starting autogen.sh..."
+ ./autogen.sh --prefix=/usr
+
+ msg2 "Starting make..."
+ make
+}
+
+package() {
+ cd $_pkgname
+
+ msg2 "Starting make install..."
+ make DESTDIR="$pkgdir" install
+
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$_pkgname/COPYING"
+}