summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée2015-06-12 14:22:15 +0200
committerMattias Andrée2015-06-12 14:22:15 +0200
commitc5a3ebfdb91e95e4fc1a5c43852859f28727dc33 (patch)
tree3ad1744e5839603d58ca7f5b02057339d021c593
downloadaur-c5a3ebfdb91e95e4fc1a5c43852859f28727dc33.tar.gz
Initial import, version 1.11.1
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD37
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9b90493b439
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = xpybar
+ pkgdesc = A highly extensible minimalistic dock panel configured in Python 3
+ pkgver = 1.11.1
+ pkgrel = 1
+ url = https://github.com/maandree/xpybar
+ arch = any
+ license = GPL3
+ license = AGPL3
+ makedepends = make
+ makedepends = coreutils
+ makedepends = sed
+ makedepends = zip
+ depends = python3
+ depends = argparser
+ depends = python-xlib
+ depends = xorg-xrandr
+ optdepends = linux: most of the monitors require Linux's procfs or sysfs
+ optdepends = curl: for Internet services
+ optdepends = python-pyalsaaudio: for ALSA volume control
+ optdepends = hdparm: hdparm: for hdparm support
+ optdepends = python-pytz: for timezone support
+ optdepends = python-sysv-ipc: for ropty example
+ optdepends = iputils: for ping support
+ optdepends = inotify-tools: for inotify support
+ optdepends = alarm: for limiting the time of a file search in locks
+ optdepends = findutils: for file search in locks
+ source = https://github.com/maandree/xpybar/archive/1.11.1.tar.gz
+ sha256sums = bf5c50ed72745b85a0eeaef080f9ca7ea913fec46d3cc02c3f9a55f501037d8b
+
+pkgname = xpybar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b78c2a7d41b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=xpybar
+pkgver=1.11.1
+pkgrel=1
+pkgdesc="A highly extensible minimalistic dock panel configured in Python 3"
+arch=(any)
+url="https://github.com/maandree/xpybar"
+license=('GPL3' 'AGPL3')
+depends=(python3 argparser python-xlib xorg-xrandr)
+optdepends=("linux: most of the monitors require Linux's procfs or sysfs"
+ "curl: for Internet services"
+ "python-pyalsaaudio: for ALSA volume control"
+ "hdparm: hdparm: for hdparm support"
+ "python-pytz: for timezone support"
+ "python-sysv-ipc: for ropty example"
+ "iputils: for ping support"
+ "inotify-tools: for inotify support"
+ "alarm: for limiting the time of a file search in locks"
+ "findutils: for file search in locks")
+makedepends=(make coreutils sed zip)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(bf5c50ed72745b85a0eeaef080f9ca7ea913fec46d3cc02c3f9a55f501037d8b)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr install DESTDIR="$pkgdir"
+ chmod 4755 "$pkgdir/usr/bin/restricted-hdparm"
+}
+