summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-01-16 19:46:07 +1300
committerGeorge Rawlinson2023-01-16 19:46:07 +1300
commit7b851a3adb79143f9de52ad4bac909e23d04f431 (patch)
treee178a6d87765ee25e8f006a972e8250f85e9955f
parent5e7585237556903f8d1148877be29b1972088e3b (diff)
downloadaur-7b851a3adb79143f9de52ad4bac909e23d04f431.tar.gz
upgpkg: xq 1.1.2-1; enable debug package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1966784a363..6f1587020313 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xq
pkgdesc = Command-line XML and HTML beautifier and content extractor
- pkgver = 1.1.1
+ pkgver = 1.1.2
pkgrel = 1
url = https://github.com/sibprogrammer/xq
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = xq
depends = glibc
conflicts = yq
options = !lto
- source = xq::git+https://github.com/sibprogrammer/xq#commit=f0c2fb2fb0dcc90e9422a219ffdf437113777388
+ source = xq::git+https://github.com/sibprogrammer/xq#commit=7c585a2e6ccd7e6e3adc63e4524023389135c938
source = manpage-template.patch
b2sums = SKIP
b2sums = f2448e22798e018d6962016dc800ff96ae9c23b776742348a7036d613efa8c37e5c8c7a539804f2daebc4c152495cc1cbbcb2635fcf223e958596333cab1b843
diff --git a/PKGBUILD b/PKGBUILD
index 8c659af67011..69eb92e56954 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: George Rawlinson <grawlinson@archlinux.org>
pkgname=xq
-pkgver=1.1.1
+pkgver=1.1.2
pkgrel=1
pkgdesc='Command-line XML and HTML beautifier and content extractor'
arch=('x86_64')
@@ -11,7 +11,7 @@ depends=('glibc')
makedepends=('git' 'go')
conflicts=('yq')
options=('!lto')
-_commit='f0c2fb2fb0dcc90e9422a219ffdf437113777388'
+_commit='7c585a2e6ccd7e6e3adc63e4524023389135c938'
source=(
"$pkgname::git+$url#commit=$_commit"
'manpage-template.patch'
@@ -45,16 +45,18 @@ build() {
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
+ export GOPATH="${srcdir}"
# commit date for binary & man page
local _commit_date=$(git show --no-patch --format=%cd --date=format:%Y-%m-%d)
go build -v \
- -trimpath \
-buildmode=pie \
-mod=readonly \
-modcacherw \
- -ldflags "-linkmode external -extldflags ${LDFLAGS} \
+ -ldflags "-compressdwarf=false \
+ -linkmode external \
+ -extldflags ${LDFLAGS} \
-X main.commit=$_commit \
-X main.date=$_commit_date \
-X main.version=$pkgver" \