summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrendan Abolivier2015-10-14 10:01:50 +0200
committerBrendan Abolivier2015-10-14 10:01:50 +0200
commit93260f5cbebac4fc7cc4d324cd3ad3c4bd3081b5 (patch)
treea76537b8bac983947827258b5af44bd2c29e97e6
downloadaur-93260f5cbebac4fc7cc4d324cd3ad3c4bd3081b5.tar.gz
Hello AUR
-rw-r--r--.PKGBUILD.swpbin0 -> 12288 bytes
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
3 files changed, 46 insertions, 0 deletions
diff --git a/.PKGBUILD.swp b/.PKGBUILD.swp
new file mode 100644
index 000000000000..ff9501dee6fd
--- /dev/null
+++ b/.PKGBUILD.swp
Binary files differ
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fbc483f6c6a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xqilla
+ pkgdesc = An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C.
+ pkgver = 2.3.2
+ pkgrel = 1
+ url = http://xqilla.sourceforge.net/
+ arch = any
+ license = GPL3
+ depends = xerces-c
+ provides = xqilla
+ source = http://downloads.sourceforge.net/project/xqilla/XQilla-2.3.2.tar.gz
+ source = https://www.apache.org/dist/xerces/c/3/sources/xerces-c-3.1.2.tar.gz
+ sha256sums = 5ae0aed4091521d5c2f541093e02a81ebe55a9087ba735f80b110068584e217c
+ sha256sums = 743bd0a029bf8de56a587c270d97031e0099fe2b7142cef03e0da16e282655a0
+
+pkgname = xqilla
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdb56890e923
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Brendan Abolivier <brendan@cozycloud.cc>
+pkgname=xqilla
+pkgver=2.3.2
+pkgrel=1
+epoch=
+pkgdesc="An XQuery and XPath 2.0 library, written in C++ and built on top of Xerces-C."
+arch=("any")
+url="http://xqilla.sourceforge.net/"
+license=("GPL3")
+groups=()
+depends=("xerces-c")
+provides=("xqilla")
+backup=()
+changelog=
+source=("http://downloads.sourceforge.net/project/xqilla/XQilla-2.3.2.tar.gz"
+ "https://www.apache.org/dist/xerces/c/3/sources/xerces-c-3.1.2.tar.gz")
+noextract=()
+sha256sums=("5ae0aed4091521d5c2f541093e02a81ebe55a9087ba735f80b110068584e217c"
+ "743bd0a029bf8de56a587c270d97031e0099fe2b7142cef03e0da16e282655a0")
+
+build() {
+ cd XQilla-2.3.2
+ ./configure --with-xerces=`pwd`/../xerces-c-3.1.2/
+ make
+}
+
+package() {
+ cd XQilla-2.3.2
+ make DESTDIR="$pkgdir/" install
+}