summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqaz2019-12-31 00:24:55 +0800
committerqaz2019-12-31 00:24:55 +0800
commitc631c2983da0e5f42ff3f17f9b277fd448d9a54f (patch)
tree7ae84cd73ee0be38297cc2d779a89e2c55c9a64c
downloadaur-c631c2983da0e5f42ff3f17f9b277fd448d9a54f.tar.gz
first commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD70
-rwxr-xr-xxqarena2
-rw-r--r--xqarena.desktop14
-rwxr-xr-xxqschool2
-rw-r--r--xqschool.desktop14
-rwxr-xr-xxqwizard2
-rw-r--r--xqwizard.desktop14
8 files changed, 150 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c9709945924
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = xqwizard
+ pkgdesc = A super powerful Chinese chess teaching, computer game and chess score editing software
+ pkgver = 5.52
+ pkgrel = 1
+ url = https://www.xqbase.com
+ arch = i686
+ arch = x86_64
+ license = custom:xqwizard
+ makedepends = icoutils
+ depends = bash
+ depends = wine
+ depends = hicolor-icon-theme
+ noextract = xqwizard_portable.7z
+ source = https://www.xqbase.com/download/xqwizard_portable.7z
+ source = https://download.microsoft.com/download/5/a/d/5ad868a0-8ecd-4bb0-a882-fe53eb7ef348/VB6.0-KB290887-X86.exe
+ source = file://xqwizard.desktop
+ source = file://xqarena.desktop
+ source = file://xqschool.desktop
+ source = file://xqwizard
+ source = file://xqarena
+ source = file://xqschool
+ sha256sums = 45f1d1b99056dc382c241d4e01bacc9ec085891ca6c3983a159352aa476f57d5
+ sha256sums = 467b5a10c369865f2021d379fc0933cb382146b702bbca4bcb703fc86f4322bb
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = xqwizard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c83499d95daa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,70 @@
+# Maintainer: qaz <fkxxyz@163.com>
+# Contributor: qaz <fkxxyz@163.com>
+
+pkgname=xqwizard
+pkgver=5.52
+pkgrel=1
+pkgdesc="A super powerful Chinese chess teaching, computer game and chess score editing software"
+arch=('i686' 'x86_64')
+url="https://www.xqbase.com"
+license=('custom:xqwizard')
+makedepends=('icoutils')
+depends=('bash' 'wine' 'hicolor-icon-theme')
+source=(
+ "https://www.xqbase.com/download/xqwizard_portable.7z"
+ "https://download.microsoft.com/download/5/a/d/5ad868a0-8ecd-4bb0-a882-fe53eb7ef348/VB6.0-KB290887-X86.exe"
+ "file://xqwizard.desktop"
+ "file://xqarena.desktop"
+ "file://xqschool.desktop"
+ "file://xqwizard"
+ "file://xqarena"
+ "file://xqschool"
+)
+noextract=(
+ "xqwizard_portable.7z"
+)
+
+prepare() {
+ cd "${srcdir}"
+ mkdir -p "pkg"
+ cd "pkg"
+ bsdtar xf ../xqwizard_portable.7z
+ bsdtar xf ../vbrun60sp6.exe msvbvm60.dll
+}
+
+build() {
+ cd "${srcdir}"
+ mkdir -p icons
+ wrestool -v -x -t 14 -o "icons" "pkg/XQWIZARD.EXE"
+ wrestool -v -x -t 14 -o "icons" "pkg/XQARENA.EXE"
+ wrestool -v -x -t 14 -o "icons" "pkg/XQSCHOOL.EXE"
+ icotool -x -o "icons" "icons/XQWIZARD.EXE_14_1.ico"
+ icotool -x -o "icons" "icons/XQARENA.EXE_14_1.ico"
+ icotool -x -o "icons" "icons/XQSCHOOL.EXE_14_1.ico"
+}
+
+package() {
+ cd "${srcdir}"
+ for n in XQWIZARD XQARENA XQSCHOOL; do
+ for s in 16 32 48; do
+ install -Dm644 icons/$n*${s}x${s}*.png "${pkgdir}/usr/share/icons/hicolor/"${s}x${s}/apps/$n.png
+ done
+ done
+ install -d "${pkgdir}/usr/share/applications"
+ install -Dm644 *.desktop "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 xqarena xqschool xqwizard "${pkgdir}/usr/bin/"
+ install -d "${pkgdir}/usr/share/licenses/xqwizard"
+ touch "${pkgdir}/usr/share/licenses/xqwizard/LICENSE"
+ cp -rf 'pkg' "${pkgdir}/usr/share/xqwizard"
+}
+
+# vim:set ts=2 sw=2 et:
+sha256sums=('45f1d1b99056dc382c241d4e01bacc9ec085891ca6c3983a159352aa476f57d5'
+ '467b5a10c369865f2021d379fc0933cb382146b702bbca4bcb703fc86f4322bb'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
diff --git a/xqarena b/xqarena
new file mode 100755
index 000000000000..4219edbeeba4
--- /dev/null
+++ b/xqarena
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec env WINEPREFIX="/home/qaz/.wine-xqwizard" WINEARCH=win32 wine /usr/share/xqwizard/XQARENA.EXE $*
diff --git a/xqarena.desktop b/xqarena.desktop
new file mode 100644
index 000000000000..c54f0a4dae0e
--- /dev/null
+++ b/xqarena.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Chess wizard arena
+Comment=Actual match games
+Name[zh_CN]=象棋巫师竞技场
+Comment[zh_CN]=实战对局游戏
+Name[zh_TW]=象棋巫師競技場
+Comment[zh_TW]=實戰對局遊戲
+StartupNotify=true
+Exec=xqarena %U
+Type=Application
+Path=/usr/share/xqwizard
+Icon=XQARENA
+Categories=Game;
+StartupWMClass=xqarena.exe
diff --git a/xqschool b/xqschool
new file mode 100755
index 000000000000..34a628958229
--- /dev/null
+++ b/xqschool
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec env WINEPREFIX="/home/qaz/.wine-xqwizard" WINEARCH=win32 wine /usr/share/xqwizard/XQSCHOOL.EXE $*
diff --git a/xqschool.desktop b/xqschool.desktop
new file mode 100644
index 000000000000..5ccc51bf2ce5
--- /dev/null
+++ b/xqschool.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Chess wizard magic school Ⅱ
+Comment=Killing and endgame exercises
+Name[zh_CN]=象棋巫师魔法学校Ⅱ
+Comment[zh_CN]=杀局和残局练习
+Name[zh_TW]=象棋巫師魔法學校Ⅱ
+Comment[zh_TW]=殺局和殘局練習
+StartupNotify=true
+Exec=xqschool %U
+Type=Application
+Path=/usr/share/xqwizard
+Icon=XQSCHOOL
+Categories=Game;
+StartupWMClass=xqschool.exe
diff --git a/xqwizard b/xqwizard
new file mode 100755
index 000000000000..766446556548
--- /dev/null
+++ b/xqwizard
@@ -0,0 +1,2 @@
+#!/bin/bash
+exec env WINEPREFIX="/home/qaz/.wine-xqwizard" WINEARCH=win32 wine /usr/share/xqwizard/XQWIZARD.EXE $*
diff --git a/xqwizard.desktop b/xqwizard.desktop
new file mode 100644
index 000000000000..89e5900c69d1
--- /dev/null
+++ b/xqwizard.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=Chess wizard
+Comment=Chinese chess teaching, computer games and chess record editing
+Name[zh_CN]=象棋巫师
+Comment[zh_CN]=中国象棋教学、电脑对弈和棋谱编辑
+Name[zh_TW]=象棋巫師
+Comment[zh_TW]=中國象棋教學、電腦對弈和棋譜編輯
+StartupNotify=true
+Exec=xqwizard %U
+Type=Application
+Path=/usr/share/xqwizard
+Icon=XQWIZARD
+Categories=Game;
+StartupWMClass=xqwizard.exe