summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergej Pupykin2017-04-11 20:53:26 +0300
committerSergej Pupykin2017-04-11 20:53:26 +0300
commit3e868945d7ad5e5af12366bda604998ae4f5feb6 (patch)
tree67ec4dd5b3c5e6eddc59801e9999897c2db22f3e
parentdb0b13269fb4c272eaf58e1cf391c474ee3e6a5f (diff)
downloadaur-3e868945d7ad5e5af12366bda604998ae4f5feb6.tar.gz
upd
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 29 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e086beb05914..a464b0754e89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,23 @@
# Generated by mksrcinfo v8
-# Mon Apr 10 17:55:21 UTC 2017
+# Tue Apr 11 17:52:39 UTC 2017
pkgbase = xradio-git
pkgdesc = Port Allwinner xradio driver to mainline Linux
pkgver = r103.9d27fae
- pkgrel = 1
+ pkgrel = 3
url = https://github.com/fifteenhex/xradio.git
+ install = xradio.install
arch = armv7h
license = GPL
makedepends = git
makedepends = linux-headers
source = git+https://github.com/fifteenhex/xradio.git
- md5sums = SKIP
+ source = http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/boot_xr819.bin
+ source = http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/fw_xr819.bin
+ source = http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/sdd_xr819.bin
+ sha256sums = SKIP
+ sha256sums = 6583350b3eb12f70fc6d6081426717bd0019b55c6558ffe820c1548f0702bb8c
+ sha256sums = 4954ceb85807959c42e82c432109455bd9eabe95971402299a16d77ddd7d79f5
+ sha256sums = 84d3fb3ca8e5d25a0c113a5063bccbeb5b53da230a0afa236b5b625f37db5161
pkgname = xradio-git
diff --git a/PKGBUILD b/PKGBUILD
index 3458da9d510b..624b3ab3958c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,13 @@
+_KVER=$(uname -r)
+#_KVER=4.10.8-1-ARCH
+
pkgname=xradio-git
pkgver=r103.9d27fae
pkgver() {
cd "$srcdir/xradio"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-pkgrel=2
+pkgrel=3
pkgdesc="Port Allwinner xradio driver to mainline Linux"
arch=(armv7h)
url="https://github.com/fifteenhex/xradio.git"
@@ -12,11 +15,14 @@ license=('GPL')
depends=()
install=xradio.install
makedepends=('git' 'linux-headers')
-source=("git+https://github.com/fifteenhex/xradio.git")
-md5sums=('SKIP')
-
-#_KVER=4.10.4-1-ARCH
-_KVER=$(uname -r)
+source=("git+https://github.com/fifteenhex/xradio.git"
+ "http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/boot_xr819.bin"
+ "http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/fw_xr819.bin"
+ "http://filez.zoobab.com/allwinner/h2/201609022/android/hardware/broadcom/wlan/bcmdhd/firmware/xr819/sdd_xr819.bin")
+sha256sums=('SKIP'
+ '6583350b3eb12f70fc6d6081426717bd0019b55c6558ffe820c1548f0702bb8c'
+ '4954ceb85807959c42e82c432109455bd9eabe95971402299a16d77ddd7d79f5'
+ '84d3fb3ca8e5d25a0c113a5063bccbeb5b53da230a0afa236b5b625f37db5161')
build() {
cd "xradio"
@@ -26,6 +32,13 @@ build() {
package() {
cd "xradio"
make -C /usr/lib/modules/${_KVER}/build M=$PWD INSTALL_MOD_PATH="$pkgdir" modules_install
+
+ # fix modules path
mkdir -p "$pkgdir"/usr
mv "$pkgdir"/lib "$pkgdir"/usr/
+
+ # install firmware
+ for i in boot fw sdd; do
+ install -Dm0644 "$srcdir"/${i}_xr819.bin "$pkgdir"/usr/lib/firmware/xr819/${i}_xr819.bin
+ done
}