summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2019-07-30 16:18:52 +0200
committerLubosz Sarnecki2019-07-30 17:32:23 +0200
commit31ae38dcd84ef58e01cbb9fe3094dd4fb8955b76 (patch)
tree265ac95bac8ac3c23e7fedd7865960e1247e7bc6
downloadaur-31ae38dcd84ef58e01cbb9fe3094dd4fb8955b76.tar.gz
Initial commit.
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD48
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c536d33e4a4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Tue Jul 30 15:31:49 UTC 2019
+pkgbase = xrdesktop-git
+ pkgdesc = A library for XR interaction with classical desktop compositors.
+ pkgver = 0.12.1.529.81bae4c
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xrdesktop/xrdesktop
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = glib2
+ depends = gxr-git
+ depends = gulkan-git
+ provides = xrdesktop=0.12.1.529.81bae4c
+ conflicts = xrdesktop
+ options = debug
+ options = !strip
+ source = git+https://gitlab.freedesktop.org/xrdesktop/xrdesktop.git
+ md5sums = SKIP
+
+pkgname = xrdesktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a49233aa7a6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Lubosz Sarnecki <lubosz.sarnecki@collabora.com>
+
+basename='xrdesktop'
+pkgname="$basename-git"
+pkgver=0.12.1.529.81bae4c
+pkgrel=1
+pkgdesc='A library for XR interaction with classical desktop compositors.'
+arch=('i686' 'x86_64')
+url='https://gitlab.freedesktop.org/xrdesktop/xrdesktop'
+depends=('glib2' 'gxr-git' 'gulkan-git')
+provides=("$basename="$pkgver)
+conflicts=("$basename")
+makedepend=('meson' 'git')
+license=('MIT')
+options=('debug' '!strip')
+
+source=('git+https://gitlab.freedesktop.org/xrdesktop/xrdesktop.git')
+
+md5sums=('SKIP')
+
+ver() {
+ PREFIX="project('xrdesktop', 'c', version: '"
+ echo $(grep "$PREFIX" meson.build | sed -e "s/${PREFIX}//" | sed "s/',//")
+}
+
+pkgver() {
+ cd $basename
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $(ver).$revision.$hash
+}
+
+build() {
+ cd $basename
+ rm -rf build
+ meson build --prefix=/usr/ --libdir=lib
+ ninja -C build
+}
+
+check() {
+ cd $basename
+ meson test -C build/ --no-suite xr --no-suite post-install
+}
+
+package() {
+ cd $basename
+ DESTDIR="$pkgdir" ninja -C build install
+}