summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGil Forsyth2015-08-28 16:31:50 -0400
committerGil Forsyth2015-08-28 16:31:50 -0400
commit4755f3130b1c358f4a4fe08d73096370266b47f4 (patch)
tree14e2c6747cd1c5f3ecd17769924089047786799c
downloadaur-4755f3130b1c358f4a4fe08d73096370266b47f4.tar.gz
initial commit. PKGBUILD builds clean
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5010cf94cda5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xrectsel
+ pkgdesc = a small program that tells you the geometry of a rectangular screen region selected with the mouse
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/lolilolicon/xrectsel
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = libx11
+ source = git://github.com/lolilolicon/xrectsel.git
+ md5sums = SKIP
+
+pkgname = xrectsel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3234ce2867dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gil Forsyth <gilforsyth@gmail.com>
+
+pkgname=xrectsel
+pkgver=1.0
+pkgrel=1
+pkgdesc="a small program that tells you the geometry of a rectangular screen region selected with the mouse"
+license=('unknown')
+arch=('i686' 'x86_64')
+url="https://github.com/lolilolicon/xrectsel"
+source=(git://github.com/lolilolicon/xrectsel.git)
+md5sums=('SKIP')
+depends=('libx11')
+makedepends=('git')
+
+build() {
+ cd "${pkgname}"
+ ./bootstrap
+ ./configure --prefix /usr
+ make
+}
+package() {
+ cd "${pkgname}"
+ install -Dm 755 xrectsel "${pkgdir}"/usr/bin/xrectsel
+}
+