summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlolilolicon2015-09-03 23:48:26 +0800
committerlolilolicon2015-09-03 23:48:26 +0800
commit7f319ff507b75243f9b9d62a2e07e87a11c15e6a (patch)
tree20035565fe09f15372ae5df2e00c2882e3b0db09
parent305ad292b29b849aff8aa88aea85f79ed006b681 (diff)
downloadaur-7f319ff507b75243f9b9d62a2e07e87a11c15e6a.tar.gz
Revert to pre-AUR4 PKGBUILD.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD39
2 files changed, 29 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43504cb26534..a2e3226d9d56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,17 @@
pkgbase = xrectsel
- pkgdesc = a small program that tells you the geometry of a rectangular screen region selected with the mouse
+ pkgdesc = print the geometry of a rectangular screen region
pkgver = 0.3.1
pkgrel = 1
url = https://github.com/lolilolicon/xrectsel
arch = i686
arch = x86_64
license = GPL3
+ makedepends = autoconf
+ makedepends = automake
depends = libx11
+ conflicts = ffcast<1:2.2.0
source = https://github.com/lolilolicon/xrectsel/archive/0.3.1.tar.gz
- md5sums = SKIP
+ md5sums = e62966f6ddbd82780a2ab2d2d94bfebb
pkgname = xrectsel
diff --git a/PKGBUILD b/PKGBUILD
index 27db6ef0abf5..ff6987eca5cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,34 @@
-# Maintainer: Gil Forsyth <gilforsyth@gmail.com>
+# Maintainer: lolilolicon <lolilolicon@gmail.com>
+_name=xrectsel
+_ver=0.3.1
pkgname=xrectsel
-pkgver=0.3.1
+pkgver=${_ver//-/}
pkgrel=1
-pkgdesc="a small program that tells you the geometry of a rectangular screen region selected with the mouse"
-license=('GPL3')
-arch=('i686' 'x86_64')
+pkgdesc="print the geometry of a rectangular screen region"
+arch=(i686 x86_64)
url="https://github.com/lolilolicon/xrectsel"
-source=("https://github.com/lolilolicon/xrectsel/archive/$pkgver.tar.gz")
-md5sums=('SKIP')
-depends=('libx11')
+license=(GPL3)
+conflicts=('ffcast<1:2.2.0') # ffcast used to ship /usr/bin/xrectsel
+depends=(libx11)
+makedepends=(autoconf automake)
+source=("https://github.com/lolilolicon/$_name/archive/$_ver.tar.gz")
+md5sums=('e62966f6ddbd82780a2ab2d2d94bfebb')
+
+prepare() {
+ cd "$_name-$_ver"
+ ./bootstrap
+}
build() {
- tar xzf "${pkgver}.tar.gz"
- cd "${pkgname}-${pkgver}"
- ./bootstrap
- ./configure --prefix /usr
- make
+ cd "$_name-$_ver"
+ ./configure --prefix /usr
+ make
}
+
package() {
- cd "${pkgname}-${pkgver}"
- install -Dm 755 xrectsel "${pkgdir}"/usr/bin/xrectsel
+ cd "$_name-$_ver"
+ make DESTDIR="$pkgdir" install
}
+# vim:st=2:sw=2:et: