summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarina Brown2016-01-09 11:57:06 -0500
committerMarina Brown2016-01-09 11:57:06 -0500
commitd3a8e95e871b2362873e7e5854ebc233ce333d5e (patch)
treecbdda8a6199c4d7818bfbea3c7635e6107dedfe7
parent035caa07652b7b787fa9b230520ca159a35fb724 (diff)
downloadaur-d3a8e95e871b2362873e7e5854ebc233ce333d5e.tar.gz
tweaking
-rw-r--r--PKGBUILD1
-rwxr-xr-x[-rw-r--r--]xroach.install29
2 files changed, 19 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18b10e774f48..db1fcf9eb4f6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -52,6 +52,7 @@ build() {
package() {
cd "$pkgname"
pwd
+ install=xroach.install
install -Dm755 xroach "$pkgdir/usr/bin/xroach"
install -Dm644 xroach.6 "$pkgdir/usr/share/man/man6/xroach.6"
}
diff --git a/xroach.install b/xroach.install
index 657bcfb5ff31..e39e3a9a582c 100644..100755
--- a/xroach.install
+++ b/xroach.install
@@ -1,14 +1,21 @@
post_install(){
-
- echo " ################################################################## "
- echo " # XROACH WILL ONLY WORK ON SIMPLE SESSION MANAGERS # "
- echo " # It will NOT work on plasma or gnome or other window # "
- echo " # managers that do not allow programs to read and write # "
- echo " # to the root window. BE AWARE !! # "
- echo " # # "
- echo " # It will work on on fvwm, twm and similar # "
- echo " ################################################################## "
-
+ echo " ------------------------------------------------------------------ "
+ echo " - XROACH WILL ONLY WORK ON SIMPLE SESSION MANAGERS - "
+ echo " - It will NOT work on plasma or gnome or other window - "
+ echo " - managers that do not allow programs to read and write - "
+ echo " - to the root window. BE AWARE !! - "
+ echo " - - "
+ echo " - It will work on on fvwm, twm and similar - "
+ echo " ------------------------------------------------------------------ "
}
-
+post_upgrade(){
+ echo " ------------------------------------------------------------------ "
+ echo " - XROACH WILL ONLY WORK ON SIMPLE SESSION MANAGERS - "
+ echo " - It will NOT work on plasma or gnome or other window - "
+ echo " - managers that do not allow programs to read and write - "
+ echo " - to the root window. BE AWARE !! - "
+ echo " - - "
+ echo " - It will work on on fvwm, twm and similar - "
+ echo " ------------------------------------------------------------------ "
+}