summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoekce2022-08-24 15:32:50 +0200
committergoekce2022-08-24 15:32:50 +0200
commitdc885ce947a306d7840bcdbfddf0799e2d5d934c (patch)
tree7dcfeaf0dd2e0ae4cf4d35ecb6fcd3563d4c5b16
parent95a785be083f2704f63c75166aec429496830bb4 (diff)
downloadaur-dc885ce947a306d7840bcdbfddf0799e2d5d934c.tar.gz
Fixed errors caused after the second run of makepkg
Rerun of `makepkg` caused problems due to existing modifications. Fixed them according to [1]. [1] https://bbs.archlinux.org/viewtopic.php?pid=2053515
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 422e8f4d9644..440900cb72cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xrt-git
pkgdesc = Xilinx runtime for Ultrascale, Versal and MPSoC-based FPGAs
- pkgver = r6625.da644adf6
+ pkgver = r6630.23657d13b
pkgrel = 1
url = https://xilinx.github.io/XRT/master/html/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 3a9e6ae3663b..e2c5a77a632b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Gökçe Aydos <aur2022@aydos.de>
_name=xrt
pkgbase=$_name-git
-pkgver=r6625.da644adf6
+pkgver=r6630.23657d13b
pkgrel=1
pkgdesc="Xilinx runtime for Ultrascale, Versal and MPSoC-based FPGAs"
arch=(x86_64)
@@ -76,7 +76,9 @@ prepare() {
git -C $_name config \
submodule.src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma.url \
../dma_ip_drivers
- git -C $_name submodule update
+ git -C $_name submodule update --force
+ # `--force` resets the branch and gets rid of the modifications.
+
echo Patch $_name/src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma
git -C $_name/src/runtime_src/core/pcie/driver/linux/xocl/lib/libqdma \
apply $srcdir/dma-ip-drivers-fixes-for-current-kernels.patch
@@ -89,7 +91,7 @@ build() {
# (`__builtin_memcpy... may overlap up to` error)
#TODO remove after resolution
CXXFLAGS=${CXXFLAGS/-Wp,-D_GLIBCXX_ASSERTIONS}
- mkdir clean-build && cd clean-build
+ mkdir -p clean-build && cd clean-build
local cmake_flags+=" -DCMAKE_BUILD_TYPE=Release"
cmake $make_flags ../src
make