summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKainoa Kanter2024-12-09 22:14:22 -0800
committerKainoa Kanter2024-12-09 22:14:22 -0800
commit9a687175cd0da95f2e6294f174855c336b7a4ec3 (patch)
tree48fdfb43654fac0ab2915ed2495e0d5359a63781
parent1766c61b8a9c8ffc5917fec65c52661d4e34caa7 (diff)
downloadaur-9a687175cd0da95f2e6294f174855c336b7a4ec3.tar.gz
metadata
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 3 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 754de93aa3ac..c2af258f5ff0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,7 +10,6 @@ pkgbase = xrt-npu-git
depends = lsb-release
depends = boost
depends = libtiff
- depends = dkms
depends = linux-headers
depends = elfutils
depends = gcc
@@ -40,6 +39,7 @@ pkgbase = xrt-npu-git
depends = pybind11
depends = xilinx-u280-gen3x16-xdma-base
optdepends = linux-mainline-um5606: Linux kernel that can use the XDNA drivers
+ optdepends = amdxdna-driver: Driver that coencides with these libaries
provides = xrt
conflicts = xrt
options = !debug
@@ -59,7 +59,6 @@ pkgname = xrt-npu-git
depends = lsb-release
depends = boost
depends = libtiff
- depends = dkms
depends = linux-headers
depends = elfutils
depends = gcc
diff --git a/PKGBUILD b/PKGBUILD
index 83039acd7f35..cff21d3997eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,6 @@ depends=(
lsb-release # Used in tests
boost
libtiff
- #cppcheck #TODO report upstream: not-needed since https://github.com/Xilinx/XRT/commit/0bd3e8c83840f341f028588a26cb9151fdd04542
- #curl #TODO report upstream: not required
- dkms
linux-headers #TODO only makedepends for dkms?
elfutils
gcc
@@ -52,6 +49,7 @@ makedepends=(
)
optdepends=(
'linux-mainline-um5606: Linux kernel that can use the XDNA drivers'
+ 'amdxdna-driver: Driver that coencides with these libaries'
)
provides=($_name)
conflicts=($_name)
@@ -80,11 +78,6 @@ pkgver() {
}
prepare() {
- # For U280 support uncomment:
- #echo Patch xocl
- #git -C xrt \
- # apply $srcdir/xocl-driver-fixes-for-current-kernels.patch
-
# Submodule integration based on
# https://wiki.archlinux.org/title/VCS_package_guidelines#Git_submodules
git -C $_name config \
@@ -95,7 +88,7 @@ prepare() {
../ELFIO
git -C $_name \
-c protocol.file.allow=always \
- submodule update --recursive
+ submodule update --recursive --init # Kainoa: added this here!
mkdir -p microblaze-fw
tar xf data.tar.gz -C microblaze-fw ./lib/firmware/xilinx
}