summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGimmeapill2019-03-24 21:49:31 +0100
committerGimmeapill2019-03-24 21:49:31 +0100
commit6ac790694298ea496251b5c32b749870af742700 (patch)
tree993ce73a69724dcf64179aa04d3da9327514be6a
downloadaur-6ac790694298ea496251b5c32b749870af742700.tar.gz
Second initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0821dd330651
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sun Mar 24 20:47:40 UTC 2019
+pkgbase = xruncounter-git
+ pkgdesc = Small tool to measure jack xruns under DSP load
+ pkgver = r6.0b383f6
+ pkgrel = 1
+ url = https://github.com/Gimmeapill/xruncounter
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = jack
+ depends = jack
+ provides = xruncounter
+ conflicts = xruncounter
+ source = xruncounter::git+https://github.com/Gimmeapill/xruncounter
+ sha256sums = SKIP
+
+pkgname = xruncounter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e86a58011ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gimmeapill <gimmeapill at gmail dot com>
+
+pkgname=xruncounter-git
+pkgver=r6.0b383f6
+pkgrel=1
+pkgdesc="Small tool to measure jack xruns under DSP load"
+arch=('i686' 'x86_64')
+url="https://github.com/Gimmeapill/xruncounter"
+license=('GPL3')
+depends=('jack')
+makedepends=('git' 'jack')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("${pkgname%-*}::git+https://github.com/Gimmeapill/xruncounter")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-*}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-*}"
+ gcc -Wall xruncounter.c -lm `pkg-config --cflags --libs jack` -o xruncounter
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-*}"
+ mkdir $pkgdir/usr
+ mkdir $pkgdir/usr/bin
+ install -m655 xruncounter "$pkgdir/usr/bin"
+}
+
+