summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:17:40 -0600
committernot_anonymous2015-07-05 18:17:40 -0600
commitea2121f5b84d50111bbf6d594b2cb9afc9428d05 (patch)
treedf9025639b0b3b4b0363c1482a12846a4ede498b
downloadaur-ea2121f5b84d50111bbf6d594b2cb9afc9428d05.tar.gz
Initial import
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD65
-rw-r--r--diff.Makefile.am35
-rw-r--r--xdemorse.pngbin0 -> 1289 bytes
-rw-r--r--xsatcom.16
-rw-r--r--xsatcom.desktop11
-rw-r--r--xsatcom.install11
7 files changed, 162 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f851afe3e57d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = xsatcom
+ pkgdesc = Ham Radio - satellite tracking.
+ pkgver = 2.9
+ pkgrel = 1
+ url = http://www.qsl.net/5b4az/pkg/satellite/xsatcom/xsatcom.html
+ install = xsatcom.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = intltool
+ makedepends = pkg-config
+ depends = gtk2
+ depends = desktop-file-utils
+ optdepends = xplanet: provides data on great circle map
+ source = http://www.qsl.net/5b4az/pkg/satellite/xsatcom/xsatcom-2.9.tar.bz2
+ source = diff.Makefile.am
+ source = xsatcom.desktop
+ source = xdemorse.png
+ source = xsatcom.1
+ md5sums = c4b41986591d00230c37281b9600a26a
+ md5sums = 9d53a30a57e2308b35f52a815768910c
+ md5sums = da46deb421a73376507b575629df5a48
+ md5sums = edcd3f301ec8ea95453d40534beb6ede
+ md5sums = 49b427b41f3e7354c2502883d7f6801b
+ sha256sums = 806882e8650f0dc6464864e4720aade7138146c8e2d42fba20dbbc6dec51c952
+ sha256sums = 9ed0f048bd2642c77a2c777e576f39fe5580d4b2435441961d55049f520fd114
+ sha256sums = cbbc674993a789a42f7117358fa7b2b959c85376656722db942c40a2ad2eece8
+ sha256sums = 857eb46c32c12333a7110fb3ea99d2246084724856638f2e04324fc2a576626d
+ sha256sums = 357c69b07dfe18090998f59d10bbaa3e24b636e177a863c67d83015160b973d2
+
+pkgname = xsatcom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d24218a8b5b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=xsatcom
+pkgver=2.9
+pkgrel=1
+pkgdesc="Ham Radio - satellite tracking."
+arch=('i686' 'x86_64')
+url="http://www.qsl.net/5b4az/pkg/satellite/xsatcom/xsatcom.html"
+license=(GPL3)
+depends=('gtk2' 'desktop-file-utils')
+makedepends=('autoconf' 'automake' 'intltool' 'pkg-config')
+optdepends=('xplanet: provides data on great circle map')
+install=$pkgname.install
+source=("http://www.qsl.net/5b4az/pkg/satellite/$pkgname/$pkgname-$pkgver.tar.bz2"
+ diff.Makefile.am
+ $pkgname.desktop
+ xdemorse.png
+ $pkgname.1)
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+
+ sed -i s:1.14:1.15: autogen.sh
+ patch -p0 < ../diff.Makefile.am
+
+ mkdir files/
+ install -m644 ../$pkgname.desktop files/$pkgname.desktop
+ install -m644 ../xdemorse.png files/$pkgname.png
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+
+# export LDFLAGS="-lm $LDFLAGS"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd $srcdir/$pkgname-$pkgver
+
+# make check
+ make -i check # sadly the intl. files. are not correct (sigh)
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps,doc/$pkgname,$pkgname}
+ make DESTDIR=$pkgdir install
+
+ mv $pkgdir/usr/bin/$pkgname $pkgdir/usr/bin/$pkgname.1
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+}
+md5sums=('c4b41986591d00230c37281b9600a26a'
+ '9d53a30a57e2308b35f52a815768910c'
+ 'da46deb421a73376507b575629df5a48'
+ 'edcd3f301ec8ea95453d40534beb6ede'
+ '49b427b41f3e7354c2502883d7f6801b')
+sha256sums=('806882e8650f0dc6464864e4720aade7138146c8e2d42fba20dbbc6dec51c952'
+ '9ed0f048bd2642c77a2c777e576f39fe5580d4b2435441961d55049f520fd114'
+ 'cbbc674993a789a42f7117358fa7b2b959c85376656722db942c40a2ad2eece8'
+ '857eb46c32c12333a7110fb3ea99d2246084724856638f2e04324fc2a576626d'
+ '357c69b07dfe18090998f59d10bbaa3e24b636e177a863c67d83015160b973d2')
diff --git a/diff.Makefile.am b/diff.Makefile.am
new file mode 100644
index 000000000000..9bb50dca0464
--- /dev/null
+++ b/diff.Makefile.am
@@ -0,0 +1,35 @@
+--- Makefile.am 2013-12-02 00:01:31.000000000 -0700
++++ Makefile.am 2015-02-20 00:04:27.779213553 -0700
+@@ -35,9 +35,23 @@
+- if test -d $(HOME)/.$(PACKAGE); then \
+- echo Working directory exists: $(HOME)/.$(PACKAGE) - not copying; \
+- else \
+- echo Copying $(PACKAGE) working directory to $(HOME)/.$(PACKAGE); \
+- cp -r $(srcdir)/.$(PACKAGE) $(HOME); \
+- fi
+-
+- echo Installing other/get_tle.sh to $(bindir)
+- cp $(srcdir)/other/get_tle.sh $(bindir)
++ if test -d $(srcdir)/.$(PACKAGE); then \
++ echo Copying .$(PACKAGE) working directory to $(DESTDIR)$(pkgdatadir)/.; \
++ cp -r $(srcdir)/.$(PACKAGE)/* $(DESTDIR)$(pkgdatadir)/.; \
++ fi
++
++ if test -d files/; then \
++ echo "cp files/$(PACKAGE).desktop $(DESTDIR)/usr/share/applications/"; \
++ cp files/$(PACKAGE).desktop $(DESTDIR)/usr/share/applications/; \
++ echo "cp files/$(PACKAGE).png $(DESTDIR)/usr/share/pixmaps/"; \
++ cp files/$(PACKAGE).png $(DESTDIR)/usr/share/pixmaps/; \
++ fi
++
++ if test -d doc/; then \
++ if !(test -d $(DESTDIR)/usr/share/doc/$(PACKAGE)); then \
++ echo "mkdir $(DESTDIR)/usr/share/doc/$(PACKAGE)/"; \
++ mkdir $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
++ fi; \
++ echo "cp -r doc/* $(DESTDIR)/usr/share/doc/$(PACKAGE)/"; \
++ cp -r doc/* $(DESTDIR)/usr/share/doc/$(PACKAGE)/; \
++ fi
++
++ echo Installing other/get_tle.sh to $(DESTDIR)$(bindir)
++ cp $(srcdir)/other/get_tle.sh $(DESTDIR)$(bindir)
diff --git a/xdemorse.png b/xdemorse.png
new file mode 100644
index 000000000000..496ea5c46758
--- /dev/null
+++ b/xdemorse.png
Binary files differ
diff --git a/xsatcom.1 b/xsatcom.1
new file mode 100644
index 000000000000..437b52409d10
--- /dev/null
+++ b/xsatcom.1
@@ -0,0 +1,6 @@
+#!/bin/bash
+if [ ! -f ~/.xsatcom/xsatcomrc ] ; then
+ mkdir -p ~/.xsatcom
+ cp /usr/share/xsatcom/* ~/.xsatcom/.
+ fi
+/usr/bin/xsatcom.1 $1
diff --git a/xsatcom.desktop b/xsatcom.desktop
new file mode 100644
index 000000000000..87518dbf6484
--- /dev/null
+++ b/xsatcom.desktop
@@ -0,0 +1,11 @@
+
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=xsatcom
+Comment=Satellite data calculation & display.
+Exec=xsatcom
+Icon=xsatcom
+Terminal=false
+Categories=Application;HamRadio;
+StartupNotify=true
diff --git a/xsatcom.install b/xsatcom.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/xsatcom.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}