summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Kurth2022-08-17 21:32:34 +0200
committerPatrick Kurth2022-08-17 21:32:34 +0200
commit29b969511e35bd41d06a47cf062f79bc2a779519 (patch)
tree94042477a48e44cf07f3d7aad66319b744c88eae
parent3b60b6c0ddd82c9c2c5c584a1639160d96cff82e (diff)
downloadaur-29b969511e35bd41d06a47cf062f79bc2a779519.tar.gz
Updated to point to official release
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cef5a560f918..0e0d78d5b95f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,24 @@
# Maintainer: Patrick Kurth <p.kurth@posteo.de>
pkgname=xschem
-pkgver=r523.ac99227
+pkgver="3.1.0"
pkgrel=1
pkgdesc="Schematic editor VLSI/ASIC/analog custom designs"
arch=('any')
url="http://github.com/StefanSchippers/xschem"
-source=("git+https://github.com/StefanSchippers/xschem.git")
-sha256sums=('SKIP')
+source=("http://repo.hu/projects/xschem/releases/xschem-$pkgver.tar.gz")
+sha256sums=('50cc069e3256197cecbab0044aabff985eca0eb92be431bd3c0d5e41feb3f509')
depends=('libx11' 'libxrender' 'libxcb' 'cairo' 'tcl' 'tk' 'libxpm' 'gawk')
-makedepends=('flex' 'bison' 'git')
+makedepends=('flex' 'bison')
license=('GPL')
-pkgver() {
- cd "${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
build() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
./configure --prefix=/usr
make
}
package() {
- cd "${srcdir}/${pkgname}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="$pkgdir/" install
}
+