summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Kurth2021-01-22 22:20:40 +0100
committerPatrick Kurth2021-01-22 22:20:40 +0100
commit3b60b6c0ddd82c9c2c5c584a1639160d96cff82e (patch)
tree774cffe61e5f6e9654ac14487af8b0da5537c4a0
downloadaur-3b60b6c0ddd82c9c2c5c584a1639160d96cff82e.tar.gz
Initial submission of 'xschem'
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD28
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f6366b9b01e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = xschem
+ pkgdesc = Schematic editor VLSI/ASIC/analog custom designs
+ pkgver = r523.ac99227
+ pkgrel = 1
+ url = http://github.com/StefanSchippers/xschem
+ arch = any
+ license = GPL
+ makedepends = flex
+ makedepends = bison
+ makedepends = git
+ depends = libx11
+ depends = libxrender
+ depends = libxcb
+ depends = cairo
+ depends = tcl
+ depends = tk
+ depends = libxpm
+ depends = gawk
+ source = git+https://github.com/StefanSchippers/xschem.git
+ sha256sums = SKIP
+
+pkgname = xschem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cef5a560f918
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Patrick Kurth <p.kurth@posteo.de>
+pkgname=xschem
+pkgver=r523.ac99227
+pkgrel=1
+pkgdesc="Schematic editor VLSI/ASIC/analog custom designs"
+arch=('any')
+url="http://github.com/StefanSchippers/xschem"
+source=("git+https://github.com/StefanSchippers/xschem.git")
+sha256sums=('SKIP')
+depends=('libx11' 'libxrender' 'libxcb' 'cairo' 'tcl' 'tk' 'libxpm' 'gawk')
+makedepends=('flex' 'bison' 'git')
+license=('GPL')
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="$pkgdir/" install
+}