summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2019-04-03 06:43:52 +0000
committerAntonio Rojas2019-04-03 06:43:52 +0000
commit988de2a18da87c0264789e53196b5072c7f49fcb (patch)
treedf79413f2d58b5be4786fb1db6f287adadb51ba1
downloadaur-988de2a18da87c0264789e53196b5072c7f49fcb.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD28
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..15e53a2d40dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = xsnow
+ pkgdesc = Display snow, Santa and his reindeers on the root window
+ pkgver = 1.42
+ pkgrel = 7
+ url = https://janswaal.home.xs4all.nl/Xsnow/
+ arch = x86_64
+ license = custom
+ makedepends = imake
+ depends = libxpm
+ source = https://janswaal.home.xs4all.nl/Xsnow/xsnow-1.42.tar.gz
+ source = LICENSE
+ sha1sums = d63987560dac9c6341e50d270089e40d17031ce3
+ sha1sums = c93e236bed35a2d5dc23202c1c615d4e146fba49
+
+pkgname = xsnow
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..b5645bacf4eb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+ Copyright
+ ---------
+ Xsnow is available freely and you may give it to other people as is,
+ but I retain all rights. Therefore it does not classify as 'Public
+ Domain' software. It *is* allowed to package Xsnow for Unix/Linux
+ distributions, CD-Roms etc, and to make the necessary changes to
+ makefiles etc. to facilitate this.
+
+©Copyright 1984, 1988, 1990, 1993-1995, 2000-2001 by Rick Jansen, all rights reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75f33e3a2353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=xsnow
+pkgver=1.42
+pkgrel=7
+pkgdesc="Display snow, Santa and his reindeers on the root window"
+arch=('x86_64')
+url="https://janswaal.home.xs4all.nl/Xsnow/"
+license=('custom')
+depends=('libxpm')
+makedepends=('imake')
+source=(https://janswaal.home.xs4all.nl/Xsnow/xsnow-$pkgver.tar.gz LICENSE)
+sha1sums=('d63987560dac9c6341e50d270089e40d17031ce3'
+ 'c93e236bed35a2d5dc23202c1c615d4e146fba49')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ xmkmf
+ make depend
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install install.man
+ chmod 644 "${pkgdir}/usr/share/man/man1/xsnow.1x"
+ install -D -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}