summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlphaJack2021-12-21 21:50:57 +0100
committerAlphaJack2021-12-21 21:50:57 +0100
commite72a2337be021fd45e5c8dd64c606727668515ae (patch)
tree57cf137cf2c54bd696258fb9fb0870ebf1392c11
downloadaur-e72a2337be021fd45e5c8dd64c606727668515ae.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD32
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5d7898bac2b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = xsnow-legacy
+ pkgdesc = Display snow, Santa and his reindeers on the root window
+ pkgver = 1.42
+ pkgrel = 1
+ url = https://janswaal.home.xs4all.nl/Xsnow/
+ arch = x86_64
+ arch = i686
+ license = custom
+ makedepends = imake
+ depends = libxpm
+ conflicts = xsnow
+ conflicts = xsnow-bin
+ source = https://janswaal.home.xs4all.nl/Xsnow/xsnow-1.42.tar.gz
+ source = LICENSE
+ sha256sums = d0d7c8f1fb91ca096995b1c30797e8f443c2e97d6f1e5f574b31318ed05d561a
+ sha256sums = 4b611ecb33d955613a7f2448f245515d0e2c4ca2f309023098b3f7dd56a62093
+
+pkgname = xsnow-legacy
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..eccc237a975c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+ Copyright
+ ---------
+ Xsnow is available freely and you may give it to other people as is,
+ but I retain all rights. Therefore it does not classify as 'Public
+ Domain' software. It *is* allowed to package Xsnow for Unix/Linux
+ distributions, CD-Roms etc, and to make the necessary changes to
+ makefiles etc. to facilitate this.
+
+Copyright 1984, 1988, 1990, 1993-1995, 2000-2001 by Rick Jansen, all rights reserved.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..368af4939038
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: AlphaJack <alphajack at tuta dot io>
+# Contributor: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname="xsnow-legacy"
+pkgver=1.42
+pkgrel=1
+pkgdesc="Display snow, Santa and his reindeers on the root window"
+url="https://janswaal.home.xs4all.nl/Xsnow/"
+license=("custom")
+arch=("x86_64" "i686")
+depends=("libxpm")
+makedepends=("imake")
+conflicts=("xsnow" "xsnow-bin")
+source=("https://janswaal.home.xs4all.nl/Xsnow/xsnow-$pkgver.tar.gz"
+ "LICENSE")
+sha256sums=("d0d7c8f1fb91ca096995b1c30797e8f443c2e97d6f1e5f574b31318ed05d561a"
+ "4b611ecb33d955613a7f2448f245515d0e2c4ca2f309023098b3f7dd56a62093")
+
+build(){
+ cd "xsnow-$pkgver"
+ xmkmf
+ make depend
+ make
+}
+
+package(){
+ cd "xsnow-$pkgver"
+ make DESTDIR="$pkgdir" install install.man
+ chmod 644 "$pkgdir/usr/share/man/man1/xsnow.1x"
+ install -D -m 644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}