summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Legner2015-06-12 11:25:37 +0200
committerSimon Legner2015-06-12 11:25:37 +0200
commit4850feabd9cbc7330688d4185b93dcace27da450 (patch)
tree106b3c2555c161583d73fa518c30a6fba64a5e3e
downloadaur-4850feabd9cbc7330688d4185b93dcace27da450.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8e2859059b24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = xspin
+ pkgdesc = Tcl/Tk GUI for spin
+ pkgver = 5.2.5
+ pkgrel = 1
+ url = http://spinroot.com/
+ arch = any
+ license = custom
+ depends = spin
+ depends = tk
+ source = http://spinroot.com/spin/Src/xspin525.tcl
+ md5sums = 4b41ff53c1834168aa183def9036bbb7
+
+pkgname = xspin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..731b1a18836e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Pierre Chapuis <catwell@archlinux.us>
+# Maintainer: Simon Legner <Simon.Legner@gmail.com>
+
+pkgname=xspin
+pkgver=5.2.5
+pkgrel=1
+pkgdesc="Tcl/Tk GUI for spin"
+arch=('any')
+url="http://spinroot.com/"
+license=('custom')
+depends=('spin' 'tk')
+source=(http://spinroot.com/spin/Src/xspin525.tcl)
+
+build() {
+ sed -i 's~#!/bin/sh~#!/usr/bin/wish -f~' xspin525.tcl
+ install -Dm0755 xspin525.tcl $pkgdir/usr/bin/xspin
+ install -Dm0644 /usr/share/licenses/spin/LICENSE.txt \
+ $pkgdir/usr/share/licenses/$pkgname/LICENSE.txt
+}
+
+md5sums=('4b41ff53c1834168aa183def9036bbb7')