summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlad Wenter2015-08-18 23:06:42 +0200
committerAlad Wenter2015-08-18 23:06:42 +0200
commitfeb3f0ce86e5490c1e167ff9308e44992e1309de (patch)
treeaf230e251d75208d6288b83dba897aa28b46db4d
parent36a9b2d916f66840191c963b730f4bd72f7628a6 (diff)
downloadaur-feb3f0ce86e5490c1e167ff9308e44992e1309de.tar.gz
fix pkgver
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD14
-rw-r--r--ignore-blank.patch83
3 files changed, 9 insertions, 90 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 855c81ddfc18..37197626f745 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = xss-lock-git
pkgdesc = Use external locker as X screen saver
- pkgver = v0.3.0.4.g1e158fb
+ pkgver = 0.3.0.r4.g1e158fb
pkgrel = 1
url = https://bitbucket.org/raymonad/xss-lock
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 46862fc0bc92..ad8d5e168496 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,26 @@
# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
# Contributor: Raymond Wagenmaker <raymondwagenmaker@gmail.com>
pkgname=xss-lock-git
-pkgver=v0.3.0.4.g1e158fb
+pkgver=0.3.0.r4.g1e158fb
pkgrel=1
+
pkgdesc="Use external locker as X screen saver"
arch=(i686 x86_64)
url="https://bitbucket.org/raymonad/xss-lock"
license=('MIT')
+
depends=('xcb-util' 'systemd')
makedepends=('cmake' 'python-docutils' 'git')
optdepends=('bash-completion: for bash completion')
-source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git")
-md5sums=('SKIP')
provides=('xss-lock')
conflicts=('xss-lock')
+source=("$pkgname::git+https://bitbucket.org/raymonad/${pkgname%-git}.git")
+md5sums=('SKIP')
+
pkgver() {
cd "$pkgname"
- local ver="$(git describe --long)"
- printf "%s" "${ver//-/.}"
+ git describe | sed 's/^v//; s/-/.r/; s/-/./'
}
build() {
@@ -30,7 +32,7 @@ build() {
package() {
cd "$pkgname"
make DESTDIR="$pkgdir" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}
# vim:set ts=2 sw=2 et:
diff --git a/ignore-blank.patch b/ignore-blank.patch
deleted file mode 100644
index a701c1f529bf..000000000000
--- a/ignore-blank.patch
+++ /dev/null
@@ -1,83 +0,0 @@
---- src/xss-lock.c.orig 2015-01-15 10:34:31.469611430 +0100
-+++ src/xss-lock.c 2015-01-15 15:51:45.360306124 +0100
-@@ -61,6 +61,7 @@
- static gboolean opt_quiet = FALSE;
- static gboolean opt_verbose = FALSE;
- static gboolean opt_ignore_sleep = FALSE;
-+static gboolean opt_ignore_blank = FALSE;
- static gboolean opt_print_version = FALSE;
-
- static GOptionEntry opt_entries[] = {
-@@ -68,6 +69,7 @@
- {"notifier", 'n', G_OPTION_FLAG_FILENAME, G_OPTION_ARG_CALLBACK, parse_notifier_cmd, "Send notification using CMD", "CMD"},
- {"transfer-sleep-lock", 'l', 0, G_OPTION_ARG_NONE, &locker.transfer_sleep_lock_fd, "Pass sleep delay lock file descriptor to locker", NULL},
- {"ignore-sleep", 0, 0, G_OPTION_ARG_NONE, &opt_ignore_sleep, "Do not lock on suspend/hibernate", NULL},
-+ {"ignore-blank", 0, 0, G_OPTION_ARG_NONE, &opt_ignore_blank, "Do not lock on screensaver events", NULL},
- {"quiet", 'q', 0, G_OPTION_ARG_NONE, &opt_quiet, "Output only fatal errors", NULL},
- {"verbose", 'v', 0, G_OPTION_ARG_NONE, &opt_verbose, "Output more messages", NULL},
- {"version", 0, 0, G_OPTION_ARG_NONE, &opt_print_version, "Print version number and exit", NULL},
-@@ -170,34 +172,36 @@
- xcb_screensaver_notify_event_t *xss_event =
- (xcb_screensaver_notify_event_t *)event;
-
-- switch (xss_event->state) {
-- case XCB_SCREENSAVER_STATE_ON:
-- if (xss_event->kind == XCB_SCREENSAVER_KIND_INTERNAL)
-- /* According to the original protocol, this forces the external
-- * saver (i.e., me) to be started after deactivating the
-- * internal saver, which may be started if the server is
-- * grabbed when the saver activates, but Xorg does not seem to
-- * work that way; I'm leaving this in anyway.
-- */
-- xcb_force_screen_saver(connection, XCB_SCREEN_SAVER_ACTIVE);
-- else if (!notifier.cmd || xss_event->forced) {
-- start_child(&locker);
-- logind_session_set_idle_hint(TRUE);
-- } else if (!locker.pid)
-- start_child(&notifier);
-- else
-- logind_session_set_idle_hint(TRUE);
-- break;
-- case XCB_SCREENSAVER_STATE_OFF:
-- kill_child(&notifier);
-- logind_session_set_idle_hint(FALSE);
-- break;
-- case XCB_SCREENSAVER_STATE_CYCLE:
-- if (!locker.pid) {
-- logind_session_set_idle_hint(TRUE);
-- start_child(&locker);
-- }
-- break;
-+ if (!opt_ignore_blank) {
-+ switch (xss_event->state) {
-+ case XCB_SCREENSAVER_STATE_ON:
-+ if (xss_event->kind == XCB_SCREENSAVER_KIND_INTERNAL)
-+ /* According to the original protocol, this forces the external
-+ * saver (i.e., me) to be started after deactivating the
-+ * internal saver, which may be started if the server is
-+ * grabbed when the saver activates, but Xorg does not seem to
-+ * work that way; I'm leaving this in anyway.
-+ */
-+ xcb_force_screen_saver(connection, XCB_SCREEN_SAVER_ACTIVE);
-+ else if (!notifier.cmd || xss_event->forced) {
-+ start_child(&locker);
-+ logind_session_set_idle_hint(TRUE);
-+ } else if (!locker.pid)
-+ start_child(&notifier);
-+ else
-+ logind_session_set_idle_hint(TRUE);
-+ break;
-+ case XCB_SCREENSAVER_STATE_OFF:
-+ kill_child(&notifier);
-+ logind_session_set_idle_hint(FALSE);
-+ break;
-+ case XCB_SCREENSAVER_STATE_CYCLE:
-+ if (!locker.pid) {
-+ logind_session_set_idle_hint(TRUE);
-+ start_child(&locker);
-+ }
-+ break;
-+ }
- }
- }
- return TRUE;