summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorarkhan2023-04-26 19:37:48 -0500
committerarkhan2023-04-26 19:37:48 -0500
commitf4ffb03309257472f47e32ea990f015c639168ad (patch)
tree6735c76ea70f3ac8a6a5cc26d680023d48edc2f3
parent57a0b60af4e2e332c70767d5cfbbba5bf4e464d4 (diff)
downloadaur-f4ffb03309257472f47e32ea990f015c639168ad.tar.gz
Update to 0.9 version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de005e05262e..8d7d2aeddeda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
pkgbase = xst
- pkgdesc = `xst` is a st fork with some patches applied and other goodies.
- pkgver = 0.8.4
- pkgrel = 2
- url = https://github.com/gnotclub/xst
+ pkgdesc = st fork fork with xresources support and other patches
+ pkgver = 0.9
+ pkgrel = 1
+ epoch = 1
+ url = https://git.sr.ht/~arkhan/xst
arch = i686
arch = x86_64
license = MIT
makedepends = ncurses
makedepends = libxext
makedepends = git
+ makedepends = harfbuzz
depends = libxft
- source = https://github.com/gnotclub/xst/archive/v0.8.4.tar.gz
- md5sums = 6757baf9f9fb62db29babc0f7d2b6493
+ source = git+https://git.sr.ht/~arkhan/xst
+ sha1sums = SKIP
pkgname = xst
-
diff --git a/PKGBUILD b/PKGBUILD
index cb22c58de891..177f561dbc8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Maintainer: Nathan Isom <Nahanisom27 at gmail [dot] com >
-# Maintainer: Edison Ibáñez <arkhan at disroot [dot] org >
-# derived from xst-git aur package.
+# Maintainer: Edison Ibáñez <arkhan at riseup [dot] net>
+# derived from st-git aur package.
pkgname=xst
-pkgver=0.8.4
-pkgrel=2
-pkgdesc='`xst` is a st fork with some patches applied and other goodies.'
-url='https://github.com/gnotclub/xst'
+epoch=1
+pkgver=0.9
+pkgrel=1
+pkgdesc='st fork fork with xresources support and other patches'
+url='https://git.sr.ht/~arkhan/xst'
arch=('i686' 'x86_64')
license=('MIT')
depends=('libxft')
-makedepends=('ncurses' 'libxext' 'git')
-source=("https://github.com/gnotclub/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=('6757baf9f9fb62db29babc0f7d2b6493')
+makedepends=('ncurses' 'libxext' 'git' 'harfbuzz')
+source=("git+https://git.sr.ht/~arkhan/${pkgname}")
+sha1sums=('SKIP')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
+ make clean
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
make PREFIX=/usr DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm644 readme.org "${pkgdir}/usr/share/doc/${pkgname}/README"
}