summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHarvettFox962021-06-30 19:08:40 +0800
committerHarvettFox962021-06-30 19:08:40 +0800
commitd3865480a4a29d5dff262acb99f422bf8bddd366 (patch)
treed1833769c65e207f14627d9c0875444e0f9e691b
downloadaur-d3865480a4a29d5dff262acb99f422bf8bddd366.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD50
2 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..143b4e6c272d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = xstarfish
+ pkgdesc = X wallpaper generator
+ pkgver = 1.1
+ pkgrel = 1
+ url = https://launchpad.net/ubuntu/+source/xstarfish/
+ arch = x86_64
+ arch = i686
+ license = GPL-2
+ makedepends = quilt
+ depends = glibc
+ depends = libpng
+ depends = libx11
+ source = https://deb.debian.org/debian/pool/main/x/xstarfish/xstarfish_1.1.orig.tar.gz
+ source = https://deb.debian.org/debian/pool/main/x/xstarfish/xstarfish_1.1-11.1.debian.tar.xz
+ sha512sums = 8f398ddc1b0c6fbf33721b48c5859d9cabbbb9dddf298daa92e3658bac69e0544516294e8ef47b948d123115d0258d1d2502bce6e51a24a8b3e99331af3047a1
+ sha512sums = 84e1d2b464ded6ca5443300b3ccad44feeb9d719cd3b6892668839713add7a9f2a668c890598b43f48c44f719ae25475a2e1723927784187a0caa7f4b9f10807
+
+pkgname = xstarfish
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..613ca682698f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Jayvee Enaguas <harvettfox96@dismail.de>
+
+pkgname=xstarfish
+pkgver=1.1
+pkgrel=1
+_debver=1.1
+_debrel=11.1
+pkgdesc="X wallpaper generator"
+arch=('x86_64' 'i686')
+url="https://launchpad.net/ubuntu/+source/xstarfish/"
+#url="http://www.redplanetsw.com/starfish/"
+license=('GPL-2')
+depends=('glibc' 'libpng' 'libx11')
+makedepends=('quilt')
+source=("https://deb.debian.org/debian/pool/main/x/${pkgname}/${pkgname}_${_debver}.orig.tar.gz"
+ "https://deb.debian.org/debian/pool/main/x/${pkgname}/${pkgname}_${_debver}-${_debrel}.debian.tar.xz")
+sha512sums=('8f398ddc1b0c6fbf33721b48c5859d9cabbbb9dddf298daa92e3658bac69e0544516294e8ef47b948d123115d0258d1d2502bce6e51a24a8b3e99331af3047a1'
+ '84e1d2b464ded6ca5443300b3ccad44feeb9d719cd3b6892668839713add7a9f2a668c890598b43f48c44f719ae25475a2e1723927784187a0caa7f4b9f10807')
+
+prepare() {
+ cd starfish-${pkgver}/
+
+ # Remove old Debian source directory.
+ rm -frv ./debian/
+
+ if [[ ${pkgver%.*} = ${_debver%.*} ]]; then
+ # Debian patches
+ export QUILT_PATCHES=debian/patches
+ export QUILT_REFRESH_ARGS='-p ab --no-timestamps --no-index'
+ export QUILT_DIFF_ARGS='--no-timestamps'
+
+ mv "$srcdir"/debian/ ./
+
+ quilt push -av
+ fi
+}
+
+build() {
+ cd starfish-${pkgver}/
+
+ make
+}
+
+package() {
+ cd starfish-${pkgver}/
+
+ # Install binary and licence files.
+ install -Dm755 starfish -t ${pkgdir}/usr/bin/
+ install -Dm644 COPYING -t ${pkgdir}/usr/share/licenses/${pkgname}/
+}