aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmish2020-01-04 23:17:48 +0530
committerAmish2020-01-04 23:17:48 +0530
commit84d05df52ea96d1592b89c95aea44435c2391ad4 (patch)
tree668f10030bc0a9a2236df46db027421cc06b0991
parent96895b74a70f7774aa9120d3a93ac07b1682b862 (diff)
downloadaur-84d05df52ea96d1592b89c95aea44435c2391ad4.tar.gz
Add support for MaxMind License Key
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD13
3 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 26fa71345b9e..3df2b9824796 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = xtables-geoip-db
pkgdesc = GeoIP Database for xtables
- pkgver = 1.0
- pkgrel = 5
+ pkgver = 1.2
+ pkgrel = 1
url = https://dev.maxmind.com/geoip/geoip2/geolite2/
arch = any
license = BSD
license = GPL
makedepends = perl-text-csv-xs
makedepends = perl-net-cidr-lite
- source = https://geolite.maxmind.com/download/geoip/database/GeoLite2-Country-CSV.zip
- source = xt_geoip_build::https://sourceforge.net/p/xtables-addons/xtables-addons/ci/v3.5/tree/geoip/xt_geoip_build?format=raw
+ source = GeoLite2-Country-CSV.zip::https://download.maxmind.com/app/geoip_download?edition_id=GeoLite2-Country-CSV&suffix=zip&license_key=XXXX
+ source = xt_geoip_build::https://sourceforge.net/p/xtables-addons/xtables-addons/ci/v3.7/tree/geoip/xt_geoip_build?format=raw
sha256sums = SKIP
sha256sums = 216cb5a8c018c9db1cbff6b8a788d71d08f1d23dbb4ae60d318fc62fab1a2b46
diff --git a/.gitignore b/.gitignore
index dd858c4001c5..534009837448 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@ xt_geoip_build
xtables-geoip-db-*.tar.gz
*-any.pkg.tar.xz
*-any.pkg.tar.xz.sig
+geoip.license.key
diff --git a/PKGBUILD b/PKGBUILD
index 3d52887b46cd..e44561f8a536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,19 @@
# Maintainer: Amish <contact at via dot aur>
pkgname=xtables-geoip-db
-pkgver=1.0
-pkgrel=5
+pkgver=1.2
+pkgrel=1
pkgdesc="GeoIP Database for xtables"
arch=('any')
license=('BSD' 'GPL')
url="https://dev.maxmind.com/geoip/geoip2/geolite2/"
makedepends=('perl-text-csv-xs' 'perl-net-cidr-lite')
-_xtver=3.5
-source=("https://geolite.maxmind.com/download/geoip/database/GeoLite2-Country-CSV.zip"
+_xtver=3.7
+
+# create a file named geoip.license.key which contains MaxMind License key in following format:
+#_maxmind_key=XXXX
+source geoip.license.key
+
+source=("GeoLite2-Country-CSV.zip::https://download.maxmind.com/app/geoip_download?edition_id=GeoLite2-Country-CSV&suffix=zip&license_key=${_maxmind_key}"
"xt_geoip_build::https://sourceforge.net/p/xtables-addons/xtables-addons/ci/v${_xtver}/tree/geoip/xt_geoip_build?format=raw")
sha256sums=('SKIP'
'216cb5a8c018c9db1cbff6b8a788d71d08f1d23dbb4ae60d318fc62fab1a2b46')