summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLev Levitsky2015-06-14 16:24:54 +0300
committerLev Levitsky2015-06-14 16:24:54 +0300
commit5a3c908f023718e3a29cab86682dcc2794cfc6fa (patch)
tree65baedba38d18834f823e97ecf11ac7b9c06b956
downloadaur-5a3c908f023718e3a29cab86682dcc2794cfc6fa.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
-rwxr-xr-xxtandem.sh1
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..922ac036a87c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Mon May 4 04:44:13 UTC 2015
+pkgbase = xtandem
+ pkgdesc = Software that can match tandem mass spectra with peptide sequences, in a process known as protein identification.
+ pkgver = 15.04.01.1
+ pkgrel = 3
+ url = http://www.thegpm.org/TANDEM/
+ arch = x86_64
+ license = custom
+ optdepends = python-pyteomics.pepxmltk: a convenient wrapper for tandem.exe and a converter to pepXML
+ source = ftp://ftp.thegpm.org/projects/tandem/source/tandem-linux-15-04-01-1.zip
+ source = xtandem.sh
+ md5sums = 6f40a80f58ef710607075e112abcbeac
+ md5sums = ddde2d73df3b72f30d5906fefaeece09
+
+pkgname = xtandem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ae68fbc06ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lev Levitsky <levlev@mail.ru>
+pkgname=xtandem
+pkgver=15.04.01.1
+pkgrel=3
+pkgdesc="Software that can match tandem mass spectra with peptide sequences, in a process known as protein identification."
+arch=('x86_64')
+url="http://www.thegpm.org/TANDEM/"
+license=('custom')
+source=("ftp://ftp.thegpm.org/projects/tandem/source/tandem-linux-${pkgver//\./-}.zip"
+ "xtandem.sh")
+md5sums=('6f40a80f58ef710607075e112abcbeac'
+ 'ddde2d73df3b72f30d5906fefaeece09')
+optdepends=('python-pyteomics.pepxmltk: a convenient wrapper for tandem.exe and a converter to pepXML')
+package() {
+ cd "tandem-linux-${pkgver//\./-}"
+ install -Dt $pkgdir/usr/bin bin/*.exe
+ install -m 644 -D LICENSE $pkgdir/usr/share/licenses/$pkgname/license.txt
+ install -Dt $pkgdir/etc/profile.d ../xtandem.sh
+}
diff --git a/xtandem.sh b/xtandem.sh
new file mode 100755
index 000000000000..b6e7014188a1
--- /dev/null
+++ b/xtandem.sh
@@ -0,0 +1 @@
+export TANDEMEXE=tandem.exe \ No newline at end of file