summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaltazár Radics2021-11-03 15:37:18 +0100
committerBaltazár Radics2021-11-03 15:37:18 +0100
commit530458edc47bdb2904bc2b2f2f905a52f4bbef1f (patch)
tree26a32a8d35257ef79f6b63d76b801a579cab9c9a
parenta8e820b277ae08ba924f530fd09cd5c8b43cfbb5 (diff)
downloadaur-530458edc47bdb2904bc2b2f2f905a52f4bbef1f.tar.gz
update to 2.37
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD42
2 files changed, 39 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b679725dfc89..69ae9ad4097b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = xtensa-esp32-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the xtensa esp32 (bare-metal) target
- pkgver = 2.35
+ pkgver = 2.37
pkgrel = 1
url = https://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
depends = libelf
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.35.tar.bz2
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.35.tar.bz2.sig
- source = xtensa-overlays-4d8c98d.tar.gz::https://codeload.github.com/espressif/xtensa-overlays/tar.gz/4d8c98d
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.37.tar.bz2
+ source = https://ftp.gnu.org/gnu/binutils/binutils-2.37.tar.bz2.sig
+ source = xtensa-overlays-a5ab689.tar.gz::https://codeload.github.com/espressif/xtensa-overlays/tar.gz/a5ab689
validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
- sha256sums = 7d24660f87093670738e58bcc7b7b06f121c0fcb0ca8fc44368d675a5ef9cff7
+ sha256sums = 67fc1a4030d08ee877a4867d3dcab35828148f87e1fd05da6db585ed5a166bd4
sha256sums = SKIP
- sha256sums = 88b054b60b8009d02184ed0703b7fe200b8965af5c45268b7e99a11820119344
+ sha256sums = 0087aac5e7015d43ff904ef984278df1f99c6757709088c52632b27dc482268f
pkgname = xtensa-esp32-elf-binutils
-
diff --git a/PKGBUILD b/PKGBUILD
index 195c2080508f..7b6521d2422e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
_target=xtensa-esp32-elf
pkgname=$_target-binutils
-pkgver=2.35
-_overlay_commit=4d8c98d
+pkgver=2.37
+_overlay_commit=a5ab689
pkgrel=1
pkgdesc='A set of programs to assemble and manipulate binary and object files for the xtensa esp32 (bare-metal) target'
arch=(x86_64)
@@ -12,9 +12,9 @@ license=(GPL)
depends=(libelf)
source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig}
xtensa-overlays-$_overlay_commit.tar.gz::https://codeload.github.com/espressif/xtensa-overlays/tar.gz/$_overlay_commit)
-sha256sums=('7d24660f87093670738e58bcc7b7b06f121c0fcb0ca8fc44368d675a5ef9cff7'
+sha256sums=('67fc1a4030d08ee877a4867d3dcab35828148f87e1fd05da6db585ed5a166bd4'
'SKIP'
- '88b054b60b8009d02184ed0703b7fe200b8965af5c45268b7e99a11820119344')
+ '0087aac5e7015d43ff904ef984278df1f99c6757709088c52632b27dc482268f')
validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
'3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
@@ -27,6 +27,30 @@ prepare() {
build() {
cd binutils-$pkgver
+ # espressif's crosstool-ng:
+ # CC_FOR_BUILD='x86_64-build_pc-linux-gnu-gcc'
+ # CFLAGS_FOR_BUILD='-O2 -g -I./.build/xtensa-esp32-elf/buildtools/include '
+ # CXXFLAGS_FOR_BUILD='-O2 -g -I./.build/xtensa-esp32-elf/buildtools/include '
+ # LDFLAGS_FOR_BUILD='-L./.build/xtensa-esp32-elf/buildtools/lib '
+ # CFLAGS='-O2 -g -pipe -I./.build/xtensa-esp32-elf/buildtools/include '
+ # CXXFLAGS='-O2 -g -pipe -I./.build/xtensa-esp32-elf/buildtools/include '
+ # LDFLAGS='-L./.build/xtensa-esp32-elf/buildtools/lib '
+ # '/usr/bin/bash'
+ # './.build/xtensa-esp32-elf/src/binutils/configure'
+ # '--build=x86_64-build_pc-linux-gnu'
+ # '--host=x86_64-build_pc-linux-gnu'
+ # '--target=xtensa-esp32-elf'
+ # '--prefix=./builds/xtensa-esp32-elf'
+ # '--disable-werror'
+ # '--enable-ld=yes'
+ # '--enable-gold=no'
+ # '--with-pkgversion=crosstool-NG esp-2020r3-5-gc65c037'
+ # '--enable-multilib'
+ # '--disable-sim'
+ # '--disable-gdb'
+ # '--disable-nls'
+ # '--with-sysroot=./builds/xtensa-esp32-elf/xtensa-esp32-elf'
+
./configure \
--target=$_target \
--with-sysroot=/usr/$_target \
@@ -39,7 +63,10 @@ build() {
--enable-ld=yes \
--enable-gold \
--enable-plugins \
- --enable-deterministic-archives
+ --enable-deterministic-archives \
+ --disable-sim \
+ --disable-gdb \
+ --disable-nls
make
}
@@ -56,11 +83,8 @@ package() {
make DESTDIR="$pkgdir" install
- # Remove file conflicting with host binutils and manpages for MS Windows tools
- # rm "$pkgdir"/usr/share/man/man1/arm-none-eabi-{dlltool,windres,windmc}*
-
# Remove info documents that conflict with host version
- rm -r "$pkgdir"/usr/share/info
+ rm -r "$pkgdir"/usr/share/info "$pkgdir"/usr/share/man "$pkgdir"/usr/lib/bfd-plugins
}
# vim: ts=2 sw=0 noet