summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBaltazár Radics2020-05-08 15:23:03 +0200
committerBaltazár Radics2020-05-08 15:23:03 +0200
commitfd6dccef2077dd8ad65db502a018cbc69bfa332c (patch)
treec373322194e1c56455f88ebb2530b200b234c3da
parent02658808cd4d68ed54a5996b802d9068fc4c17a7 (diff)
downloadaur-fd6dccef2077dd8ad65db502a018cbc69bfa332c.tar.gz
Added xtensa-overlays
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 92ee5eb5ca60..d71b039d04db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = xtensa-esp32-elf-binutils
pkgdesc = A set of programs to assemble and manipulate binary and object files for the xtensa esp32 (bare-metal) target
pkgver = 2.34
- pkgrel = 1
+ pkgrel = 2
url = https://www.gnu.org/software/binutils/
arch = x86_64
license = GPL
depends = libelf
source = https://ftp.gnu.org/gnu/binutils/binutils-2.34.tar.bz2
- source = https://ftp.gnu.org/gnu/binutils/binutils-2.34.tar.bz2.sig
- validpgpkeys = EAF1C276A747E9ED86210CBAC3126D3B4AE55E93
- validpgpkeys = 3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F
+ source = xtensa-overlays-fe9a594.tar.gz::https://codeload.github.com/espressif/xtensa-overlays/tar.gz/fe9a594
sha256sums = 89f010078b6cf69c23c27897d686055ab89b198dddf819efb0a4f2c38a0b36e6
- sha256sums = SKIP
+ sha256sums = 025a16d88ae7b17c013ed23beb02b8545b44673d2b8ecca748e63a79d5c1070d
pkgname = xtensa-esp32-elf-binutils
diff --git a/PKGBUILD b/PKGBUILD
index b2015b702755..89f91ae5c83b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,25 @@
_target=xtensa-esp32-elf
pkgname=$_target-binutils
pkgver=2.34
-pkgrel=1
+_overlay_commit=fe9a594
+pkgrel=2
pkgdesc='A set of programs to assemble and manipulate binary and object files for the xtensa esp32 (bare-metal) target'
arch=(x86_64)
url='https://www.gnu.org/software/binutils/'
license=(GPL)
depends=(libelf)
-source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2{,.sig})
+source=(https://ftp.gnu.org/gnu/binutils/binutils-$pkgver.tar.bz2 # {,.sig}
+ xtensa-overlays-$_overlay_commit.tar.gz::https://codeload.github.com/espressif/xtensa-overlays/tar.gz/$_overlay_commit)
sha256sums=('89f010078b6cf69c23c27897d686055ab89b198dddf819efb0a4f2c38a0b36e6'
- 'SKIP')
-validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
- '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
+# 'SKIP'
+ '025a16d88ae7b17c013ed23beb02b8545b44673d2b8ecca748e63a79d5c1070d')
+#validpgpkeys=('EAF1C276A747E9ED86210CBAC3126D3B4AE55E93' # Tristan Gingold <gingold@adacore.com>
+# '3A24BC1E8FB409FA9F14371813FCEF89DD9E3C4F') # Nick Clifton (Chief Binutils Maintainer) <nickc@redhat.com>
prepare() {
cd binutils-$pkgver
sed -i "/ac_cpp=/s/\$CPPFLAGS/\$CPPFLAGS -O2/" libiberty/configure
+ cp -r ../xtensa-overlays-$_overlay_commit/xtensa_esp32/binutils/* .
}
build() {