summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchenss2018-09-16 10:13:17 +0800
committerchenss2018-09-16 10:13:17 +0800
commit080c649930e17d1f3f7e7d8b9fa30bafb6cac055 (patch)
treefaeaba186ab8ec71fa731895607c38fa4618237a
downloadaur-080c649930e17d1f3f7e7d8b9fa30bafb6cac055.tar.gz
Init
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD28
-rwxr-xr-xxtensa-lx106-elf-gcc.install18
-rwxr-xr-xxtensa-lx106-elf-gcc.sh1
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c68d8650caf3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = xtensa-lx106-elf-gcc-bin
+ pkgdesc = ESP8266 GCC Cross-compiler Toolchain
+ pkgver = 1.22.0_88_gde0bdc1_4.8.5
+ pkgrel = 2
+ url = https://github.com/espressif/ESP8266_RTOS_SDK
+ install = xtensa-lx106-elf-gcc.install
+ arch = x86_64
+ license = GPL
+ depends = sh
+ provides = xtensa-lx106-elf-gcc
+ conflicts = xtensa-lx106-elf-gcc
+ options = !strip
+ options = libtool
+ options = staticlibs
+ options = emptydirs
+ source = xtensa-lx106-elf-gcc.install
+ source = xtensa-lx106-elf-gcc.sh
+ source = https://dl.espressif.com/dl/xtensa-lx106-elf-linux64-1.22.0-88-gde0bdc1-4.8.5.tar.gz
+ sha256sums = 8fa5e234d15686f29b679b6808b2f8971c0e3271859502c295ee8420b6ab0d53
+ sha256sums = 9b9499713cb6911616ded8bd3b82568e9d602540e2ff1ca4d996ff06e80c0c0a
+ sha256sums = 08486ae82e6349b61b83bb2c66f706718638523bd71810f2f2d7b3d17b829a7a
+
+pkgname = xtensa-lx106-elf-gcc-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..583b8e8109ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Chenss <ufbycd@163.com>
+
+_pkgname=xtensa-lx106-elf-gcc
+pkgname=$_pkgname-bin
+pkgver=1.22.0_88_gde0bdc1_4.8.5
+pkgrel=2
+pkgdesc="ESP8266 GCC Cross-compiler Toolchain"
+arch=('x86_64')
+url="https://github.com/espressif/ESP8266_RTOS_SDK"
+license=('GPL')
+options=(!strip libtool staticlibs emptydirs)
+provides=("xtensa-lx106-elf-gcc")
+conflicts=("xtensa-lx106-elf-gcc")
+depends=('sh')
+optdepends=()
+install=$_pkgname.install
+source=($_pkgname.install
+ "$_pkgname.sh"
+ "https://dl.espressif.com/dl/xtensa-lx106-elf-linux64-1.22.0-88-gde0bdc1-4.8.5.tar.gz")
+sha256sums=('8fa5e234d15686f29b679b6808b2f8971c0e3271859502c295ee8420b6ab0d53'
+ '9b9499713cb6911616ded8bd3b82568e9d602540e2ff1ca4d996ff06e80c0c0a'
+ '08486ae82e6349b61b83bb2c66f706718638523bd71810f2f2d7b3d17b829a7a')
+
+package() {
+ install -d "$pkgdir"/opt/$_pkgname
+ cp -af xtensa-lx106-elf/* "$pkgdir"/opt/$_pkgname
+ install -Dm755 $_pkgname.sh "$pkgdir"/etc/profile.d/$_pkgname.sh
+}
diff --git a/xtensa-lx106-elf-gcc.install b/xtensa-lx106-elf-gcc.install
new file mode 100755
index 000000000000..a8c956fa5799
--- /dev/null
+++ b/xtensa-lx106-elf-gcc.install
@@ -0,0 +1,18 @@
+
+post_install() {
+ echo "To use the toolchain, environment variables have to be set in your shell."
+ echo "Files setting them for POSIX compatible shells (bash, zsh, ...)"
+ echo "provided and should be used automatically for shells opened from now on."
+ echo "To use the toolchain right away, use"
+ echo " $ source /etc/profile.d/xtensa-lx106-elf-gcc.sh # (for POSIX compatible)"
+ echo "You may add /opt/xtensa-lx106-elf-gcc/bin to your \$PATH for selected shells."
+}
+
+post_upgrade() {
+ post_install
+
+ if [[ $(vercmp "$2" "r47-2") -ne 1 && $(vercmp "r47-3" "$1") -ne 1 ]]; then
+ echo "Note: The provided tools are not added to the \$PATH automatically anymore."
+ echo " This caused problems with other toolchains using the same executable names."
+ fi
+}
diff --git a/xtensa-lx106-elf-gcc.sh b/xtensa-lx106-elf-gcc.sh
new file mode 100755
index 000000000000..f8bd872b3b9e
--- /dev/null
+++ b/xtensa-lx106-elf-gcc.sh
@@ -0,0 +1 @@
+export PATH=${PATH}:/opt/xtensa-lx106-elf-gcc/bin