summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchn2021-04-23 15:43:15 +0800
committerchn2021-04-23 15:43:15 +0800
commit01ea5dc654aa234e8574cc93349b830febb569c9 (patch)
tree1f34a8439a2862d857c9286676a89584651d7672
parentc95083e8a12ef71eb3496d40887200c05bf34d75 (diff)
downloadaur-01ea5dc654aa234e8574cc93349b830febb569c9.tar.gz
0.12.6-2
-rw-r--r--.SRCINFO8
-rw-r--r--001-install-libdeps.patch11
-rw-r--r--PKGBUILD16
3 files changed, 29 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f1200fee489..b245b00d19f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = xtensor-io
pkgdesc = xtensor plugin to read and write images, audio files, numpy (compressed) npz and HDF5
pkgver = 0.12.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xtensor-stack/xtensor-io
arch = any
license = BSD-3-Clause
@@ -10,10 +10,14 @@ pkgbase = xtensor-io
depends = openimageio
depends = libsndfile
depends = zlib
+ depends = highfive
+ depends = hdf5
depends = blosc
depends = gdal
source = xtensor-io-0.12.6.tar.gz::https://github.com/xtensor-stack/xtensor-io/archive/0.12.6.tar.gz
- sha512sums = b73f180097540da998ff9b6974050e335d7c4e33c3c46c0f3abdedffc44eb59ba6cdba1508885a71e7749f3bc3a9ff1499e105332dff5e2b5e23e2e96e542924
+ source = 001-install-libdeps.patch
+ md5sums = 8ac452c45cb33104b381b01d7283d2ee
+ md5sums = 0eb14beeb17d2f6d9813e29e78643c48
pkgname = xtensor-io
diff --git a/001-install-libdeps.patch b/001-install-libdeps.patch
new file mode 100644
index 000000000000..7ab9a9d561ad
--- /dev/null
+++ b/001-install-libdeps.patch
@@ -0,0 +1,11 @@
+--- xtensor-io-0.12.6/CMakeLists.txt 2021-04-19 20:16:40.000000000 +0800
++++ xtensor-io-0.12.6/CMakeLists.txt 2021-04-23 15:30:39.746307455 +0800
+@@ -284,7 +284,7 @@
+ include(GNUInstallDirs)
+ include(CMakePackageConfigHelpers)
+
+-install(TARGETS xtensor-io
++install(TARGETS xtensor-io libdeps
+ EXPORT ${PROJECT_NAME}-targets)
+
+ export(EXPORT ${PROJECT_NAME}-targets
diff --git a/PKGBUILD b/PKGBUILD
index e487ecd8aca0..88586a8ee8db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: chn <g897331845@gmail.com>
pkgname=xtensor-io
pkgver=0.12.6
-pkgrel=1
+pkgrel=2
pkgdesc="xtensor plugin to read and write images, audio files, numpy (compressed) npz and HDF5"
arch=('any')
url="https://github.com/xtensor-stack/xtensor-io"
license=('BSD-3-Clause')
-depends=('xtensor' 'openimageio' 'libsndfile' 'zlib' 'blosc' 'gdal')
+depends=('xtensor' 'openimageio' 'libsndfile' 'zlib' 'highfive' 'hdf5' 'blosc' 'gdal')
makedepends=('cmake')
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/xtensor-stack/xtensor-io/archive/${pkgver}.tar.gz")
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/xtensor-stack/xtensor-io/archive/${pkgver}.tar.gz"
+ '001-install-libdeps.patch')
+
+prepare() {
+ cd "$srcdir"
+ patch -Np0 < 001-install-libdeps.patch
+}
build() {
cd "${pkgname}-${pkgver}"
@@ -20,6 +26,7 @@ build() {
-DHAVE_OIIO=ON \
-DHAVE_SndFile=ON \
-DHAVE_ZLIB=ON \
+ -DHAVE_HighFive=ON \
-DHAVE_Blosc=ON \
-DHAVE_GDAL=ON \
..
@@ -31,4 +38,5 @@ package() {
make install
}
-sha512sums=('b73f180097540da998ff9b6974050e335d7c4e33c3c46c0f3abdedffc44eb59ba6cdba1508885a71e7749f3bc3a9ff1499e105332dff5e2b5e23e2e96e542924')
+md5sums=('8ac452c45cb33104b381b01d7283d2ee'
+ '0eb14beeb17d2f6d9813e29e78643c48')