summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBeej Jorgensen2015-07-28 21:49:30 -0700
committerBeej Jorgensen2015-07-28 21:49:30 -0700
commit950954f17a7aae1478f56b4096d5b0a49ec2f42d (patch)
tree68f69bec6c390b51c18be1a4a09260e67d6bc3f4
downloadaur-950954f17a7aae1478f56b4096d5b0a49ec2f42d.tar.gz
Version 2.14-1
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD63
-rw-r--r--xtide-2.14-aur.patch103
-rw-r--r--xtide.conf2
-rw-r--r--xtide.desktop10
5 files changed, 205 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6503ae062016
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = xtide
+ pkgdesc = Harmonic tide clock and tide predictor
+ pkgver = 2.14
+ pkgrel = 1
+ url = http://www.flaterco.com/xtide/xtide.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = xaw3d
+ depends = libpng
+ depends = libtcd
+ optdepends = gpsd: for automatic location finding
+ optdepends = xtide-wvs: for hi-res vector coastlines
+ backup = etc/xtide/xtide.conf
+ source = ftp://ftp.flaterco.com/xtide/harmonics-dwf-20141224-free.tar.bz2
+ source = ftp://ftp.flaterco.com/xtide/xtide-2.14.tar.bz2
+ source = xtide-2.14-aur.patch
+ source = xtide.conf
+ source = xtide.desktop
+ md5sums = 27adcccb2824ac45b072636b1ee1cdd5
+ md5sums = 0f50833e6f686eca16dcb33c1719cf6c
+ md5sums = 6b95a3602898b45bb0079740e4859660
+ md5sums = 24c362cc119e413408318bd1eea04846
+ md5sums = eb5ebe8432103880ff3331f3236b3e74
+
+pkgname = xtide
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17da6198ccd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+# Maintainer: Beej Jorgensen <beej@beej.us>
+pkgname=xtide
+pkgver=2.14
+pkgrel=1
+pkgdesc="Harmonic tide clock and tide predictor"
+arch=('i686' 'x86_64')
+url="http://www.flaterco.com/xtide/xtide.html"
+license=('GPL')
+depends=('xaw3d' 'libpng' 'libtcd')
+optdepends=(
+ 'gpsd: for automatic location finding'
+ 'xtide-wvs: for hi-res vector coastlines'
+)
+backup=("etc/$pkgname/$pkgname.conf")
+source=('ftp://ftp.flaterco.com/xtide/harmonics-dwf-20141224-free.tar.bz2'
+ "ftp://ftp.flaterco.com/xtide/$pkgname-$pkgver.tar.bz2"
+ "${pkgname}-$pkgver-aur.patch"
+ "${pkgname}.conf"
+ "${pkgname}.desktop"
+)
+md5sums=('27adcccb2824ac45b072636b1ee1cdd5'
+ '0f50833e6f686eca16dcb33c1719cf6c'
+ '6b95a3602898b45bb0079740e4859660'
+ '24c362cc119e413408318bd1eea04846'
+ 'eb5ebe8432103880ff3331f3236b3e74')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # patch to look for conf in /etc/xtide
+ patch -Np1 < ../$pkgname-$pkgver-aur.patch
+
+ ./configure --prefix=/usr --sbindir=/usr/bin
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ local hver=20141224
+ local hdir=harmonics-dwf-${hver}
+ local hfile=${hdir}-free.tcd
+
+ # install harmonics file
+ install -D -m0644 $srcdir/$hdir/$hfile "$pkgdir/usr/share/$pkgname/$hfile"
+
+ # config file
+ install -D -m0644 $srcdir/${pkgname}.conf $pkgdir/etc/$pkgname/${pkgname}.conf
+
+ # desktop file
+ install -D -m0644 $srcdir/${pkgname}.desktop $pkgdir/usr/share/applications/${pkgname}.desktop
+
+ # binary
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+
+ # icon
+ install -D -m0644 iconsrc/icon_48x48_orig.png $pkgdir/usr/share/pixmaps/${pkgname}.png
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/xtide-2.14-aur.patch b/xtide-2.14-aur.patch
new file mode 100644
index 000000000000..93e89868d776
--- /dev/null
+++ b/xtide-2.14-aur.patch
@@ -0,0 +1,103 @@
+diff -Naur xtide-2.14/INSTALL xtide-2.14-aur/INSTALL
+--- xtide-2.14/INSTALL 2014-11-02 16:35:56.000000000 -0800
++++ xtide-2.14-aur/INSTALL 2015-07-28 21:40:03.615566071 -0700
+@@ -151,7 +151,7 @@
+ If you are installing as root, then it is recommended that you add
+ this definition to a system-wide script such as /etc/profile if you
+ have one.
+- 2. The other way is by creating the file /etc/xtide.conf. The
++ 2. The other way is by creating the file /etc/xtide/xtide.conf. The
+ environment variable, if set, takes precedence over the config
+ file.
+ If a configuration file is used, the first line should consist of
+@@ -163,7 +163,7 @@
+
+ Either set the environment variable WVS_DIR to the name of that
+ directory or supply the directory name as the second line of the
+- configuration file /etc/xtide.conf.
++ configuration file /etc/xtide/xtide.conf.
+
+ III. Run the configure script
+
+diff -Naur xtide-2.14/libxtide/Global.cc xtide-2.14-aur/libxtide/Global.cc
+--- xtide-2.14/libxtide/Global.cc 2014-10-11 12:38:53.000000000 -0700
++++ xtide-2.14-aur/libxtide/Global.cc 2015-07-28 21:38:05.266652364 -0700
+@@ -221,7 +221,7 @@
+ #ifdef UseLocalFiles
+ static const char confFile[] = "xtide.conf";
+ #else
+- static const char confFile[] = "/etc/xtide.conf";
++ static const char confFile[] = "/etc/xtide/xtide.conf";
+ #endif
+ static bool firstCall (true);
+ static SafeVector<Dstr> xtideConfLines (2U);
+@@ -408,10 +408,10 @@
+ break;
+ case Error::NO_HFILE_PATH:
+ text_out += "NO_HFILE_PATH\n\
+-If /etc/xtide.conf is not provided, you must set the environment variable\n\
++If /etc/xtide/xtide.conf is not provided, you must set the environment variable\n\
+ HFILE_PATH to point to your harmonics files. Example:\n\
+ export HFILE_PATH=/usr/local/share/xtide/harmonics.tcd\n\
+-Please refer to the documentation for usage of /etc/xtide.conf.";
++Please refer to the documentation for usage of /etc/xtide/xtide.conf.";
+ break;
+ case Error::NO_HFILE_IN_PATH:
+ text_out += "NO_HFILE_IN_PATH\n\
+diff -Naur xtide-2.14/README xtide-2.14-aur/README
+--- xtide-2.14/README 2014-11-02 16:35:56.000000000 -0800
++++ xtide-2.14-aur/README 2015-07-28 21:40:33.693595803 -0700
+@@ -1112,7 +1112,7 @@
+ If you are installing as root, then it is recommended that you add
+ this definition to a system-wide script such as /etc/profile if you
+ have one.
+- 2. The other way is by creating the file /etc/xtide.conf. The
++ 2. The other way is by creating the file /etc/xtide/xtide.conf. The
+ environment variable, if set, takes precedence over the config
+ file.
+ If a configuration file is used, the first line should consist of
+@@ -1124,7 +1124,7 @@
+
+ Either set the environment variable WVS_DIR to the name of that
+ directory or supply the directory name as the second line of the
+- configuration file /etc/xtide.conf.
++ configuration file /etc/xtide/xtide.conf.
+
+ III. Run the configure script
+
+diff -Naur xtide-2.14/tide.1 xtide-2.14-aur/tide.1
+--- xtide-2.14/tide.1 2014-06-20 18:45:48.000000000 -0700
++++ xtide-2.14-aur/tide.1 2015-07-28 21:38:49.523753018 -0700
+@@ -65,7 +65,7 @@
+ .BR http://www.flaterco.com/xtide/ .
+ .SH CONFIGURATION
+ Unless a configuration file
+-.B /etc/xtide.conf
++.B /etc/xtide/xtide.conf
+ is supplied, you must set the environment variable
+ .B HFILE_PATH
+ to point to the harmonics
+diff -Naur xtide-2.14/xtide.1 xtide-2.14-aur/xtide.1
+--- xtide-2.14/xtide.1 2014-05-04 12:49:53.000000000 -0700
++++ xtide-2.14-aur/xtide.1 2015-07-28 21:39:03.302850354 -0700
+@@ -71,7 +71,7 @@
+ .BR http://www.flaterco.com/xtide/ .
+ .SH CONFIGURATION
+ Unless a configuration file
+-.B /etc/xtide.conf
++.B /etc/xtide/xtide.conf
+ is supplied, you must set the environment variable
+ .B HFILE_PATH
+ to point to the harmonics
+diff -Naur xtide-2.14/xttpd.8 xtide-2.14-aur/xttpd.8
+--- xtide-2.14/xttpd.8 2014-06-20 18:45:48.000000000 -0700
++++ xtide-2.14-aur/xttpd.8 2015-07-28 21:39:17.161942458 -0700
+@@ -92,7 +92,7 @@
+ .BR http://www.flaterco.com/xtide/ .
+ .SH CONFIGURATION
+ Unless a configuration file
+-.B /etc/xtide.conf
++.B /etc/xtide/xtide.conf
+ is supplied, you must set the environment variable
+ .B HFILE_PATH
+ to point to the harmonics
diff --git a/xtide.conf b/xtide.conf
new file mode 100644
index 000000000000..509c305f8c9b
--- /dev/null
+++ b/xtide.conf
@@ -0,0 +1,2 @@
+/usr/share/xtide/harmonics-dwf-20141224-free.tcd
+/usr/share/xtide
diff --git a/xtide.desktop b/xtide.desktop
new file mode 100644
index 000000000000..28797874041f
--- /dev/null
+++ b/xtide.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=XTide
+Comment=Harmonic tide clock and tide predictor
+Exec=xtide
+Icon=xtide
+Terminal=false
+StartupNotify=false
+Categories=Science;Education;